Camel
  1. Camel
  2. CAMEL-4398

Add profile to camel-core pom.xml to have tools.jar added as dependency which is needed for CI servers

    Details

    • Type: Task Task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.2, 2.9.0
    • Component/s: build system
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      See nabble
      http://camel.465427.n5.nabble.com/Jenkins-dependency-in-camel-core-pom-xml-for-SNAPSHOTs-tp4749494p4749494.html

      Jenkins will by default insert dependency if missing in published pom.xml, which have hardcoded link path to jenkins server.
      Instead we need to add a profile which is based on java.home path.

      See the links from the nabble talk above.

        Activity

        Daniel Kulp added a comment -

        I have a better fix for this....

        The tools jar is required for the schemagen stuff, not the OSGi stuff. In anycase, a better fix is coming.

        Claus Ibsen added a comment -

        We should upgrade the bundle plugin as it does not need the special versioning stuff that the antrun plugin does, which drags in the tools JAR

        Claus Ibsen added a comment -

        Sorry the issue is the tools JAR is added as dep on the SNAPSHOTs, but not on the releases etc. So its a bit weird. Track down to be possible in parent/pom.xml with some antrun tasks that does some osgi versioning regex replacement.

        And since this dependency is added to camel-core it gets inheirted by all the other artifcats. But only for SNAPSHOTs, and not releases. So I guess the release profile makes something different.

        The tools JAR is thus not needed at all as a dependency to use Camel, so what we want is to get rid of tools JAR in the camel-core/pom.xml file.


          People

          • Assignee:
            Daniel Kulp
            Reporter:
            Claus Ibsen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development