Camel
  1. Camel
  2. CAMEL-4351

Impossible to use placeholders in endpointName and serviceName attributes of cxf:cxfEndpoint

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.7.3
    • Fix Version/s: 2.9.0
    • Component/s: camel-cxf
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      Here is how endpointName and serviceName are declared in XSD.

      <xsd:attribute name="endpointName" type="xsd:QName" /> 
      <xsd:attribute name="serviceName" type="xsd:QName" /> 
      

      So the xml parser fails to parse the following element

      <cxf:cxfEndpoint id="service" address="${http.service.endpoint.path}" wsdlURL="${http.service.wsdl.path}"
          serviceName="${http.service.serviceName}"
          endpointName="${http.service.portName}">
      </cxf:cxfEndpoint>
      

        Issue Links

          Activity

          Sergey Zhemzhitsky created issue -
          Sergey Zhemzhitsky made changes -
          Field Original Value New Value
          Description Here is how endpointName and serviceName are declared in XSD.

          <xsd:attribute name="endpointName" type="xsd:QName" />
          <xsd:attribute name="serviceName" type="xsd:QName" />

          So the xml parser fails to parse the following element

          <cxf:cxfEndpoint id="service" address="${http.service.endpoint.path}" wsdlURL="${http.service.wsdl.path}"
              serviceName="edi:${http.service.serviceName}"
              endpointName="edi:${http.service.portName}">
          </cxf:cxfEndpoint>


          Here is how endpointName and serviceName are declared in XSD.

          {code}
          <xsd:attribute name="endpointName" type="xsd:QName" />
          <xsd:attribute name="serviceName" type="xsd:QName" />
          {code}

          So the xml parser fails to parse the following element

          {code}
          <cxf:cxfEndpoint id="service" address="${http.service.endpoint.path}" wsdlURL="${http.service.wsdl.path}"
              serviceName="edi:${http.service.serviceName}"
              endpointName="edi:${http.service.portName}">
          </cxf:cxfEndpoint>
          {code}

          Sergey Zhemzhitsky made changes -
          Description Here is how endpointName and serviceName are declared in XSD.

          {code}
          <xsd:attribute name="endpointName" type="xsd:QName" />
          <xsd:attribute name="serviceName" type="xsd:QName" />
          {code}

          So the xml parser fails to parse the following element

          {code}
          <cxf:cxfEndpoint id="service" address="${http.service.endpoint.path}" wsdlURL="${http.service.wsdl.path}"
              serviceName="edi:${http.service.serviceName}"
              endpointName="edi:${http.service.portName}">
          </cxf:cxfEndpoint>
          {code}

          Here is how endpointName and serviceName are declared in XSD.

          {code}
          <xsd:attribute name="endpointName" type="xsd:QName" />
          <xsd:attribute name="serviceName" type="xsd:QName" />
          {code}

          So the xml parser fails to parse the following element

          {code}
          <cxf:cxfEndpoint id="service" address="${http.service.endpoint.path}" wsdlURL="${http.service.wsdl.path}"
              serviceName="${http.service.serviceName}"
              endpointName="${http.service.portName}">
          </cxf:cxfEndpoint>
          {code}

          Claus Ibsen made changes -
          Link This issue is related to CAMEL-3510 [ CAMEL-3510 ]
          Claus Ibsen added a comment -

          I assume you use Spring, and that ${ } is spring property placeholders, right?

          Claus Ibsen made changes -
          Issue Type Bug [ 1 ] Improvement [ 4 ]
          Sergey Zhemzhitsky added a comment -

          Hi Claus,

          That's right. This is spring property placeholders.

          Willem Jiang made changes -
          Assignee Willem Jiang [ njiang ]
          Willem Jiang added a comment -

          Hi Sergey,

          I just commit a quick fix for it, you have to add a customer converter to covert the String into QName like this.

            <bean id="conversionService"
                class="org.springframework.context.support.ConversionServiceFactoryBean">
              <property name="converters">
                  <list>
                      <bean class="org.apache.camel.component.cxf.spring.QNameConverter"/>
                  </list>
              </property>
            </bean>
          
          

          Can you try it with latest camel trunk for it ?

          Willem

          Sergey Zhemzhitsky added a comment -

          Hi Willem,

          I will try it and will let you know about the results.

          Willem Jiang added a comment -

          I just committed a new patch, you don't need to add to customer converter as I just showed now.

          Sergey Zhemzhitsky made changes -
          Attachment CxfEndpointBeans.xml.patch [ 12492217 ]
          Sergey Zhemzhitsky added a comment - - edited

          Hi Willem,

          I've just tested the new functionality and the attached patch for the CxfEndpointBeans.xml makes the test failed.

          Here is the stacktrace

          Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'myEndpoint': Error setting property
          values; nested exception is org.springframework.beans.NotWritablePropertyException: Invalid property 'endpointNameString' of bean class
           [org.apache.cxf.jaxws.JaxWsProxyFactoryBean]: Bean property 'endpointNameString' is not writable or has an invalid setter method. Does
           the parameter type of the setter match the return type of the getter?
                  at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.applyPropertyValues(AbstractAutowireCapableBean
          Factory.java:1361)
                  at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.populateBean(AbstractAutowireCapableBeanFactory
          .java:1086)
                  at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.configureBean(AbstractAutowireCapableBeanFactor
          y.java:314)
                  at org.springframework.beans.factory.wiring.BeanConfigurerSupport.configureBean(BeanConfigurerSupport.java:146)
                  at org.apache.cxf.configuration.spring.ConfigurerImpl.configureBean(ConfigurerImpl.java:151)
                  at org.apache.cxf.configuration.spring.ConfigurerImpl.configureBean(ConfigurerImpl.java:115)
                  at org.apache.camel.component.cxf.CxfSpringEndpoint.configure(CxfSpringEndpoint.java:225)
                  at org.apache.camel.component.cxf.CxfSpringEndpoint.createClient(CxfSpringEndpoint.java:117)
                  at org.apache.camel.component.cxf.CxfProducer.<init>(CxfProducer.java:71)
                  at org.apache.camel.component.cxf.CxfEndpoint.createProducer(CxfEndpoint.java:153)
                  at org.apache.camel.impl.ProducerCache.doGetProducer(ProducerCache.java:377)
                  ... 86 more
          Caused by: org.springframework.beans.NotWritablePropertyException: Invalid property 'endpointNameString' of bean class [org.apache.cxf.
          jaxws.JaxWsProxyFactoryBean]: Bean property 'endpointNameString' is not writable or has an invalid setter method. Does the parameter ty
          pe of the setter match the return type of the getter?
                  at org.springframework.beans.BeanWrapperImpl.setPropertyValue(BeanWrapperImpl.java:1024)
                  at org.springframework.beans.BeanWrapperImpl.setPropertyValue(BeanWrapperImpl.java:903)
                  at org.springframework.beans.AbstractPropertyAccessor.setPropertyValues(AbstractPropertyAccessor.java:76)
                  at org.springframework.beans.AbstractPropertyAccessor.setPropertyValues(AbstractPropertyAccessor.java:58)
                  at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.applyPropertyValues(AbstractAutowireCapableBean
          Factory.java:1358)
                  ... 96 more
          

          Properties endpointNameString, serviceNameString seem to be applied to ClientProxyFactoryBean, ClientFactoryBean, ServerFactoryBean, JaxWsServerFactoryBean, and these classes don't have such properties.

          Willem Jiang added a comment -

          Hi Sergey,

          I can reproduce the error, will look into it later.
          Thanks for pointing that out.

          Willem Jiang added a comment -

          Hi Sergey,
          I just committed a quick fix for the issue that you met.
          Do you mind try it again ?

          Thanks,

          Willem

          Sergey Zhemzhitsky added a comment -

          Hi Willem,

          I've just tried the latest version from the trunk.
          Now everything works like a charm.
          Thank you very much for such a great help.

          Regards,
          Sergey

          Willem Jiang made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Fix Version/s 2.9.0 [ 12316374 ]
          Resolution Fixed [ 1 ]
          Willem Ning Jiang <ningjiang@apache.org> committed 84d9a5872c32b6cd78661dbb8eba651b82dce9f7 (3 files)
          Reviews: none

          Merged revisions 1163231 via svnmerge from https://svn.apache.org/repos/asf/camel/trunk
          ........
            r1163231 | ningjiang | 2011-08-30 22:31:46 +0800 (Tue, 30 Aug 2011) | 1 line
            
            CAMEL-4351 removed SpringCXFEndpoint configure method as it should not be used anymore
          ........


          git-svn-id: https://svn.apache.org/repos/asf/camel/branches/camel-2.8.x@1167449 13f79535-47bb-0310-9956-ffa450edef68

          ningjiang committed 1167449 (4 files)
          J. Daniel Kulp <dkulp@apache.org> committed 415b1c1398364669a16b5d67c05e720ba7953cf7 (0 files)
          Reviews: none

          Blocked revisions 1152250,1152789,1162130,1162303,1162716,1162753,1162771,1163153,1169608,1170077,1170079,1170215,1170397,1170482-1170483,1170499,1170542,1170643,1170670,1170675,1170695,1170854,1171007,1171054,1171058,1171063,1171065,1171087,1171112,1171134,1171156 via svnmerge
          ........
            r1152250 | davsclaus | 2011-07-29 10:57:33 -0400 (Fri, 29 Jul 2011) | 1 line
            
            CAMEL-4283: Fixed dump as xml if message is already xml.
          ........
            r1152789 | davsclaus | 2011-08-01 10:14:06 -0400 (Mon, 01 Aug 2011) | 1 line
            
            CAMEL-4288: Added showFiles option to log formatter.
          ........
            r1162130 | cschneider | 2011-08-26 10:44:26 -0400 (Fri, 26 Aug 2011) | 1 line
            
            CAMEL-4385 Test case that shows the problem
          ........
            r1162303 | davsclaus | 2011-08-27 03:12:20 -0400 (Sat, 27 Aug 2011) | 1 line
            
            Disabled test which fails due an issue with exchange copy. Added TODO. We want the tests to pass to have CI servers test all the stuff for us
          ........
            r1162716 | ningjiang | 2011-08-29 06:17:04 -0400 (Mon, 29 Aug 2011) | 1 line
            
            CAMEL-4351 Fixed the issue of placeholders in endpointName and serviceName attributes of cxf:cxfEndpoint
          ........
            r1162753 | cschneider | 2011-08-29 07:42:15 -0400 (Mon, 29 Aug 2011) | 1 line
            
            CAMEL-4385 Fix and test for bug
          ........
            r1162771 | ningjiang | 2011-08-29 08:47:00 -0400 (Mon, 29 Aug 2011) | 1 line
            
            CAMEL-4351 removed the need of customer QNameConverter
          ........
            r1163153 | ningjiang | 2011-08-30 05:19:11 -0400 (Tue, 30 Aug 2011) | 1 line
            
            CAMEL-3510 cxf namespace supports Camel properties placeholder out of the box
          ........
            r1169608 | davsclaus | 2011-09-12 01:52:11 -0400 (Mon, 12 Sep 2011) | 1 line
            
            Trying to fix compilation on earlier versions of JDK6 on windows boxes as reported by Apache Jenkins CI servers.
          ........
            r1170077 | davsclaus | 2011-09-13 04:18:08 -0400 (Tue, 13 Sep 2011) | 1 line
            
            CAMEL-3742: Upgraded camel-jpa to JPA2 spec. Thanks to Ioannis for the patch.
          ........
            r1170079 | davsclaus | 2011-09-13 04:21:19 -0400 (Tue, 13 Sep 2011) | 1 line
            
            CAMEL-4440: camel-csv now always return a List to be consistent regardless if 0, 1 or more rows returned. Thanks to Ioannis for the patch.
          ........
            r1170215 | davsclaus | 2011-09-13 11:42:48 -0400 (Tue, 13 Sep 2011) | 1 line
            
            CAMEL-4401: Resequencer validate exchange before accepting. Added option ignoreInvalidExchanges.
          ........
            r1170397 | hadrian | 2011-09-13 20:17:00 -0400 (Tue, 13 Sep 2011) | 1 line
            
            CAMEL-4448. Upgrade to org.restlet:2.0.9
          ........
            r1170482 | cschneider | 2011-09-14 05:01:37 -0400 (Wed, 14 Sep 2011) | 1 line
            
            CAMEL-4428 Introduce ModelCamelContext for all methods that reference model classes. These methods are deprecated in CamelContext
          ........
            r1170483 | ningjiang | 2011-09-14 05:03:51 -0400 (Wed, 14 Sep 2011) | 1 line
            
            Added an unit test to lookup the spring beans when using ejb component
          ........
            r1170499 | davsclaus | 2011-09-14 05:31:24 -0400 (Wed, 14 Sep 2011) | 1 line
            
            CAMEL-4401: Catch IAE exception only
          ........
            r1170542 | cschneider | 2011-09-14 07:25:51 -0400 (Wed, 14 Sep 2011) | 1 line
            
            CAMEL-4358 Moving management API from spi.management to api.management as it is no service provider interface
          ........
            r1170643 | cschneider | 2011-09-14 10:33:26 -0400 (Wed, 14 Sep 2011) | 1 line
            
            CAMEL-4358 Fixed compile failure in camel-spring
          ........
            r1170670 | cschneider | 2011-09-14 11:05:15 -0400 (Wed, 14 Sep 2011) | 1 line
            
            CAMEL-4358 Fixed compile failure in camel-jpa
          ........
            r1170675 | cschneider | 2011-09-14 11:14:44 -0400 (Wed, 14 Sep 2011) | 1 line
            
            CAMEL-4358 Fixed compile failure in camel-sql
          ........
            r1170695 | cschneider | 2011-09-14 11:52:23 -0400 (Wed, 14 Sep 2011) | 1 line
            
            CAMEL-4417 Move ExpressionAdapter and ExpressionSupport to support
          ........
            r1170854 | hadrian | 2011-09-14 17:28:12 -0400 (Wed, 14 Sep 2011) | 1 line
            
            CAMEL-4451. Use valid URIs in camel-restlet
          ........
            r1171007 | davsclaus | 2011-09-15 04:44:54 -0400 (Thu, 15 Sep 2011) | 1 line
            
            CAMEL-3742: Fixed tests. Must use ant task for OpenJPA enhancement to better control what happens
          ........
            r1171054 | cschneider | 2011-09-15 07:05:03 -0400 (Thu, 15 Sep 2011) | 1 line
            
            CAMEL-4453 Use ErrorHandlerFactory instead of Builder. Remove error handler from ProcessorDefinition and add it in RouteDefinition
          ........
            r1171058 | cschneider | 2011-09-15 07:21:13 -0400 (Thu, 15 Sep 2011) | 1 line
            
            Fixing checkstyle error
          ........
            r1171063 | cschneider | 2011-09-15 07:50:40 -0400 (Thu, 15 Sep 2011) | 1 line
            
            Fix for compile error
          ........
            r1171065 | cschneider | 2011-09-15 07:55:04 -0400 (Thu, 15 Sep 2011) | 1 line
            
            CAMEL-4453 Fix compile error
          ........
            r1171087 | davsclaus | 2011-09-15 09:15:13 -0400 (Thu, 15 Sep 2011) | 1 line
            
            Polished README.txt file in examples.
          ........
            r1171112 | hadrian | 2011-09-15 10:32:05 -0400 (Thu, 15 Sep 2011) | 1 line
            
            CAMEL-4425. Create SipEndpoint with valid URI
          ........
            r1171134 | davsclaus | 2011-09-15 11:27:21 -0400 (Thu, 15 Sep 2011) | 1 line
            
            Use camel-parent in parent in the pom.xml file.
          ........
            r1171156 | cschneider | 2011-09-15 12:01:04 -0400 (Thu, 15 Sep 2011) | 1 line
            
            CAMEL-4357 Also moving MainSupport to main as it needs the same references like the view package
          ........


          git-svn-id: https://svn.apache.org/repos/asf/camel/branches/camel-2.8.x@1173265 13f79535-47bb-0310-9956-ffa450edef68

          Daniel Kulp committed 1173265 (1 file)
          Reviews: none

          Blocked revisions 1152250,1152789,1162130,1162303,1162716,1162753,1162771,1163153,1169608,1170077,1170079,1170215,1170397,1170482-1170483,1170499,1170542,1170643,1170670,1170675,1170695,1170854,1171007,1171054,1171058,1171063,1171065,1171087,1171112,1171134,1171156 via svnmerge

          ........
            r1152250 | davsclaus | 2011-07-29 10:57:33 -0400 (Fri, 29 Jul 2011) | 1 line
            
            CAMEL-4283: Fixed dump as xml if message is already xml.
          ........
            r1152789 | davsclaus | 2011-08-01 10:14:06 -0400 (Mon, 01 Aug 2011) | 1 line
            
            CAMEL-4288: Added showFiles option to log formatter.
          ........
            r1162130 | cschneider | 2011-08-26 10:44:26 -0400 (Fri, 26 Aug 2011) | 1 line
            
            CAMEL-4385 Test case that shows the problem
          ........
            r1162303 | davsclaus | 2011-08-27 03:12:20 -0400 (Sat, 27 Aug 2011) | 1 line
            
            Disabled test which fails due an issue with exchange copy. Added TODO. We want the tests to pass to have CI servers test all the stuff for us
          ........
            r1162716 | ningjiang | 2011-08-29 06:17:04 -0400 (Mon, 29 Aug 2011) | 1 line
            
            CAMEL-4351 Fixed the issue of placeholders in endpointName and serviceName attributes of cxf:cxfEndpoint
          ........
            r1162753 | cschneider | 2011-08-29 07:42:15 -0400 (Mon, 29 Aug 2011) | 1 line
            
            CAMEL-4385 Fix and test for bug
          ........
            r1162771 | ningjiang | 2011-08-29 08:47:00 -0400 (Mon, 29 Aug 2011) | 1 line
            
            CAMEL-4351 removed the need of customer QNameConverter
          ........
            r1163153 | ningjiang | 2011-08-30 05:19:11 -0400 (Tue, 30 Aug 2011) | 1 line
            
            CAMEL-3510 cxf namespace supports Camel properties placeholder out of the box
          ........
            r1169608 | davsclaus | 2011-09-12 01:52:11 -0400 (Mon, 12 Sep 2011) | 1 line
            
            Trying to fix compilation on earlier versions of JDK6 on windows boxes as reported by Apache Jenkins CI servers.
          ........
            r1170077 | davsclaus | 2011-09-13 04:18:08 -0400 (Tue, 13 Sep 2011) | 1 line
            
            CAMEL-3742: Upgraded camel-jpa to JPA2 spec. Thanks to Ioannis for the patch.
          ........
            r1170079 | davsclaus | 2011-09-13 04:21:19 -0400 (Tue, 13 Sep 2011) | 1 line
            
            CAMEL-4440: camel-csv now always return a List to be consistent regardless if 0, 1 or more rows returned. Thanks to Ioannis for the patch.
          ........
            r1170215 | davsclaus | 2011-09-13 11:42:48 -0400 (Tue, 13 Sep 2011) | 1 line
            
            CAMEL-4401: Resequencer validate exchange before accepting. Added option ignoreInvalidExchanges.
          ........
            r1170397 | hadrian | 2011-09-13 20:17:00 -0400 (Tue, 13 Sep 2011) | 1 line
            
            CAMEL-4448. Upgrade to org.restlet:2.0.9
          ........
            r1170482 | cschneider | 2011-09-14 05:01:37 -0400 (Wed, 14 Sep 2011) | 1 line
            
            CAMEL-4428 Introduce ModelCamelContext for all methods that reference model classes. These methods are deprecated in CamelContext
          ........
            r1170483 | ningjiang | 2011-09-14 05:03:51 -0400 (Wed, 14 Sep 2011) | 1 line
            
            Added an unit test to lookup the spring beans when using ejb component
          ........
            r1170499 | davsclaus | 2011-09-14 05:31:24 -0400 (Wed, 14 Sep 2011) | 1 line
            
            CAMEL-4401: Catch IAE exception only
          ........
            r1170542 | cschneider | 2011-09-14 07:25:51 -0400 (Wed, 14 Sep 2011) | 1 line
            
            CAMEL-4358 Moving management API from spi.management to api.management as it is no service provider interface
          ........
            r1170643 | cschneider | 2011-09-14 10:33:26 -0400 (Wed, 14 Sep 2011) | 1 line
            
            CAMEL-4358 Fixed compile failure in camel-spring
          ........
            r1170670 | cschneider | 2011-09-14 11:05:15 -0400 (Wed, 14 Sep 2011) | 1 line
            
            CAMEL-4358 Fixed compile failure in camel-jpa
          ........
            r1170675 | cschneider | 2011-09-14 11:14:44 -0400 (Wed, 14 Sep 2011) | 1 line
            
            CAMEL-4358 Fixed compile failure in camel-sql
          ........
            r1170695 | cschneider | 2011-09-14 11:52:23 -0400 (Wed, 14 Sep 2011) | 1 line
            
            CAMEL-4417 Move ExpressionAdapter and ExpressionSupport to support
          ........
            r1170854 | hadrian | 2011-09-14 17:28:12 -0400 (Wed, 14 Sep 2011) | 1 line
            
            CAMEL-4451. Use valid URIs in camel-restlet
          ........
            r1171007 | davsclaus | 2011-09-15 04:44:54 -0400 (Thu, 15 Sep 2011) | 1 line
            
            CAMEL-3742: Fixed tests. Must use ant task for OpenJPA enhancement to better control what happens
          ........
            r1171054 | cschneider | 2011-09-15 07:05:03 -0400 (Thu, 15 Sep 2011) | 1 line
            
            CAMEL-4453 Use ErrorHandlerFactory instead of Builder. Remove error handler from ProcessorDefinition and add it in RouteDefinition
          ........
            r1171058 | cschneider | 2011-09-15 07:21:13 -0400 (Thu, 15 Sep 2011) | 1 line
            
            Fixing checkstyle error
          ........
            r1171063 | cschneider | 2011-09-15 07:50:40 -0400 (Thu, 15 Sep 2011) | 1 line
            
            Fix for compile error
          ........
            r1171065 | cschneider | 2011-09-15 07:55:04 -0400 (Thu, 15 Sep 2011) | 1 line
            
            CAMEL-4453 Fix compile error
          ........
            r1171087 | davsclaus | 2011-09-15 09:15:13 -0400 (Thu, 15 Sep 2011) | 1 line
            
            Polished README.txt file in examples.
          ........
            r1171112 | hadrian | 2011-09-15 10:32:05 -0400 (Thu, 15 Sep 2011) | 1 line
            
            CAMEL-4425. Create SipEndpoint with valid URI
          ........
            r1171134 | davsclaus | 2011-09-15 11:27:21 -0400 (Thu, 15 Sep 2011) | 1 line
            
            Use camel-parent in parent in the pom.xml file.
          ........
            r1171156 | cschneider | 2011-09-15 12:01:04 -0400 (Thu, 15 Sep 2011) | 1 line
            
            CAMEL-4357 Also moving MainSupport to main as it needs the same references like the view package
          ........

          Willem Jiang made changes -
          Fix Version/s 2.8.2 [ 12317866 ]
          Willem Jiang made changes -
          Fix Version/s 2.8.2 [ 12317866 ]

            People

            • Assignee:
              Willem Jiang
              Reporter:
              Sergey Zhemzhitsky
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development