Camel
  1. Camel
  2. CAMEL-4096

camel-http - Issue with reusing cached http producer with authenticated user

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.5.0
    • Component/s: camel-http
    • Labels:
      None

      Description

      See nabble
      http://camel.465427.n5.nabble.com/Multiple-remote-connection-to-the-same-host-but-different-users-tp4309456p4309456.html

      We should keep auth information in endpoint key, so using a different credential will not re-using cached with another credential.

      This problem is most likely also in camel-http4.

        Activity

        Claus Ibsen created issue -
        Ben O'Day made changes -
        Field Original Value New Value
        Assignee Ben O'Day [ boday ]
        Ben O'Day added a comment -

        I haven't been able to reproduce this issue. From my testing, the producer cache uses the endpoint URI as the key which is unique because the user/password are part of the URI. Perhaps, I'm missing something though. Any thoughts on this?

        Willem Jiang added a comment -

        I just checked the change log , and found this issue should be fix last year.
        You can find more information in CAMEL-2945.

        Willem Jiang added a comment -

        This issue was already fixed in CAMEL 2.5.0

        Willem Jiang made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 2.5.0 [ 12315689 ]
        Fix Version/s 2.8.0 [ 12316226 ]
        Resolution Fixed [ 1 ]
        Ben O'Day made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        14d 18h 30m 1 Willem Jiang 28/Jun/11 04:17
        Resolved Resolved Closed Closed
        1m 8s 1 Ben O'Day 28/Jun/11 04:18

          People

          • Assignee:
            Ben O'Day
            Reporter:
            Claus Ibsen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development