Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.6.0
    • Fix Version/s: 3.0.0
    • Component/s: camel-core
    • Labels:
      None

      Description

      We should add an ExchangeBuilder so you can use the builder pattern to create an Exchange and set message body, headers etc.

      Something along the lines like this. Maybe there is a shorter and nicer API to do it:

      Exchange exchange = ExchangeBuilder(context).withBody("Hello World).andHeader("foo", 123).build("activemq:queue:foo");
      

        Issue Links

          Activity

          Claus Ibsen created issue -
          Richard Kettelerij made changes -
          Field Original Value New Value
          Link This issue duplicates CAMEL-3104 [ CAMEL-3104 ]
          Richard Kettelerij added a comment -

          Closed as duplicate of CAMEL-3104.

          Richard Kettelerij made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Duplicate [ 3 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          91d 23h 56m 1 Richard Kettelerij 04/Jun/11 12:44

            People

            • Assignee:
              Unassigned
              Reporter:
              Claus Ibsen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development