Camel
  1. Camel
  2. CAMEL-3229

Update poms to reduce warnings with Maven 3

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.4.0
    • Fix Version/s: 2.5.0
    • Component/s: None
    • Labels:
      None
    • Patch Info:
      Patch Available

      Description

      The poms currently generate a bunch of warnings with Maven 3. Fixing those should help make the builds more reproducible and start making it work better with Maven 3.

      1. patch.txt
        10 kB
        Daniel Kulp

        Activity

        Claus Ibsen made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Claus Ibsen added a comment -

        Closing all resolved tickets from 2010 or older

        Jeff Turner made changes -
        Project Import Sat Nov 27 00:14:50 EST 2010 [ 1290834890113 ]
        Hadrian Zbarcea made changes -
        Fix Version/s 2.5.0 [ 12320 ]
        Affects Version/s 2.4.0 [ 12250 ]
        Description
        The poms currently generate a bunch of warnings with Maven 3. Fixing those should help make the builds more reproducible and start making it work better with Maven 3.
        The poms currently generate a bunch of warnings with Maven 3. Fixing those should help make the builds more reproducible and start making it work better with Maven 3.
        Hadrian Zbarcea made changes -
        Resolution Fixed [ 1 ]
        Status In Progress [ 3 ] Resolved [ 5 ]
        Hadrian Zbarcea added a comment -

        Patch applied (rev: 1022200) with thanks to Dan. We need more from you!

        Hadrian Zbarcea made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Hadrian Zbarcea made changes -
        Assignee Hadrian Zbarcea [ hadrian ]
        Daniel Kulp made changes -
        Field Original Value New Value
        Attachment patch.txt [ 19734 ]
        Daniel Kulp added a comment -


        I'm attaching a patch that fixes all the warnings EXCEPT those due to the use of the java.net maven 1 repo. Maven 3 does not support the legacy format anymore. Thus, that repo needs to be removed. I'll work on that in a subsequent patch, but this patch is at least a start.

        Daniel Kulp created issue -

          People

          • Assignee:
            Hadrian Zbarcea
            Reporter:
            Daniel Kulp
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development