Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-20692

camel-cxf - No Payload is logged when the logging feature is enabled

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Minor
    • Resolution: Fixed
    • 3.22.1
    • 3.22.2, 4.0.6, 4.4.3, 4.6.0
    • camel-cxf
    • None
    • Unknown

    Description

      When start a CXF Soap service via endpoint cxf:// with loggingFeatureEnabled=true,
      for instance "cxf://http://127.0.0.1:8020/services/BeanAsService?dataFormat=PAYLOAD ...... &loggingFeatureEnabled=true"

      The REQ_IN and RESP_OUT messages are logged when calling the Soap service.

      But missing the Payload(body) in the messages. (only the ServiceName/PortName/PortTypeName/Headers are logged)

      Attached a demo project can be used to reproduce this issue.

      (while the "cxfrs://" endpoint with loggingFeatureEnabled=true is able to have the Payload logged as expected when calling the service)

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            nfilotto Nicolas Filotto
            xldai Xilai Dai
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment