Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-19695

camel-google-bigquery - Upgrade org.json to resolve CVE-2022-45688

    XMLWordPrintableJSON

Details

    • Dependency upgrade
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 3.20.6, 3.21.0
    • 3.20.7, 3.21.1, 3.22.0
    • camel-google-bigquery
    • None
    • Unknown

    Description

      The component camel-google-bigquery indirectly depends on org.json:json:jar:20200518:compile which has a know CVE https://nvd.nist.gov/vuln/detail/CVE-2022-45688 that can be fixed by upgrading it to 20230227 or higher.

      Attachments

        Issue Links

          Activity

            People

              nfilotto Nicolas Filotto
              nfilotto Nicolas Filotto
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: