Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-19191

Use 5.1.x version to be compatible with SB

    XMLWordPrintableJSON

Details

    • Dependency upgrade
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • None
    • 4.0-M3, 4.0.0
    • camel-http
    • None
    • Unknown

    Description

      SB works with 5.1.x, and 5.2.x is not backwards compabile. You get a ClassNotFoundException if running on SB.

      If you run this example (remove the http client dependencies in pom.xml) to reproduce
      https://github.com/apache/camel-spring-boot-examples/tree/main/kamelet-chucknorris

      If we downsgrade to 5.1.x in camel-http then this should work OOTB

      Attachments

        Issue Links

          Activity

            People

              nfilotto Nicolas Filotto
              davsclaus Claus Ibsen
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: