Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-19173

Splitting long uris in xml-io DSL doesn't work

Agile BoardAttach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Resolved
    • Minor
    • Resolution: Fixed
    • 3.20.2, 4.0-M2
    • 3.21.0, 4.0-M3, 4.0.0
    • camel-spring-boot
    • None
    • Unknown

    Description

      Splitting long uris in XML DSL as described in https://camel.apache.org/manual/faq/how-do-i-configure-endpoints.html#HowdoIconfigureendpoints-Configuringlongurisusingnewlines doesn't work on camel-spring-boot

       

      To reproduce:

      • check out camel-spring-boot-examples
      • navigate do the xml subdirectory
      • in src/main/resources/camel/my-route.xml modify from thus:

              <from uri="timer:hello?period={{timer.period}}&
                  repeatCount=10"/>

      • run mvn spring-boot:run

      result:

      org.apache.camel.FailedToCreateRouteException: Failed to create route hello: Route(hello)[From[timer:hello?period=timer.period&      ... because of Failed to resolve endpoint: timer://hello?+++++++{}{}{}{}{}repeatCount=10&period=2000 due to: Failed to resolve endpoint: timer://hello?{}{}{}{}{}+++++++repeatCount=10&period=2000 due to: There are 1 parameters that couldn't be set on the endpoint. Check the uri if the parameters are spelt correctly and that they are properties of the endpoint. Unknown parameters=[

      {             repeatCount=10}

      ]

       

       

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            davsclaus Claus Ibsen
            jsz Jacek Szymański
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment