Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-17884

Guava is overriden to an older version in bigquery starter

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Minor
    • Resolution: Fixed
    • None
    • 3.17.0
    • camel-spring-boot
    • None
    • Unknown

    Description

      camel-bigquery component declares dependency of com.google.guava:guava using google-cloud-guava-version property which is version 30.0-jre

      However the parent pom of camel-spring-boot overrides it with google-guava-version property which is an older version 20.0

      See the dependency:tree of camel-google-bigquery-starter

      mvn dependency:tree -f components-starter/camel-google-bigquery-starter/pom.xml |grep guava
      [INFO] |  +- com.google.guava:guava:jar:20.0:compile
      

      After the fix to use the google-cloud-guava-version property

      mvn dependency:tree -f components-starter/camel-google-bigquery-starter/pom.xml |grep guava|grep google
      [INFO] +- com.google.guava:guava:jar:30.0-jre:compile
      

      Attachments

        Issue Links

          Activity

            People

              acosentino Andrea Cosentino
              claudio4j Claudio Miranda
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: