Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-17136

Upgrade to Jarkarta EE APIs

Agile BoardAttach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Dependency upgrade
    • Status: Resolved
    • Major
    • Resolution: Implemented
    • None
    • 4.0-M1, 4.0.0
    • None
    • None
    • Unknown

    Description

      After the 3.14.x LTS release and when we drop Java 8, then it would be a good time to migrate to Jakarta EE APIs.

      We should look at Spring Boot and Quarkus if they are supporting these newer APIs as well or not. And then align when they are ready.

      Attachments

        Issue Links

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            Unassigned Unassigned
            davsclaus Claus Ibsen
            Votes:
            3 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment