There are 3 pairs of serializer/deserialiser properties on the Kafka component.
The inconsistent parts of the names are highlighted
I think it would be worth making these names consistent.
It looks like there was an intent to denote the key- and value- properties as expecting a class FQN string by appending 'Class' to the name. I don't see any other properties that do this so I think the consistent approach is to leave it off.
I've made an assumption that valueDeserializer & serializerClass are a pair, as the descriptions don't match. It would be good to take the opportunity to make all six descriptions consistent.