Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-14308

Upgrade to Kafka 2.4.x

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.1.0
    • Component/s: camel-kafka
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      Kafka 2.4.0 was released. We should upgrade when we can.
      And we can try to get zookeeper upgraded also as kafka uses the new 3.5.5 release.

      OSGi likely need SMX team to do a kafka 2.4.0 bundle release. And it uses Scala 2.13 I think.

      And SB should likely also support Kafka 2.4.x.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                acosentino Andrea Cosentino
                Reporter:
                davsclaus Claus Ibsen
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: