Camel
  1. Camel
  2. CAMEL-1424

Bean component - improve method selection logic for overloaded methods

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.6.0
    • Fix Version/s: 1.6.1, 2.0-M2
    • Component/s: camel-core
    • Labels:
      None

      Description

      If end users have overloaded methods with different types as method parameter Camel should try to find the method with exact type match from the payload.

      See nabble:
      http://www.nabble.com/Is-it-possible-to-overload-a-bean-method--td22338316s22882.html

      There are no Sub-Tasks for this issue.

        Activity

        Claus Ibsen added a comment -

        Reuse the logic from ExceptionPolicyStrategy that finds the best suited onException for a given thrown Exception.

        Claus Ibsen added a comment -

        CAMEL-1488 could be a duplicate of this one

        Claus Ibsen added a comment -

        BeanInfo have a flaw with overloaded methods. As operations only holds a key with the operation name.

        Claus Ibsen added a comment - - edited

        2.0: 758600, 758692
        1.x: 758605, 758700

        Claus Ibsen added a comment -

        Closing all 2.0M2 tickets


          People

          • Assignee:
            Claus Ibsen
            Reporter:
            Claus Ibsen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development