Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-14140

Remove global dependency on outdated guava

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Reopened
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: 3.x
    • Component/s: None
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      Currently, camel comes with google-guava-version=19.0 which contains a number of deprecated APIs that have been removed in 20.x. AFAICS, cassandra-3.x is the only component that depends on these deprecated guava APIs. This dependency has been removed in cassandra-4.x, which is currently in alpha. In WildFly-Camel, I confirmed that it should generally be possible to update to guava-26.x as long as cassandra can still use 19.x

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                tdiesler Thomas Diesler
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 20m
                  20m