Camel
  1. Camel
  2. CAMEL-1380

Aggregator - completedPredicate should be renamed to completionPredicate to be in line with wording

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0-M1
    • Component/s: camel-core
    • Labels:
      None

      Description

                  <aggregate strategyRef="bestQuote">
                      <correlationExpression>
                          <header id="loandId"/>
                      </correlationExpression>
                      <completedPredicate>
                          <simple>${header.CamelAggregatedCount} > 2</simple>
                      </completedPredicate>
                  </aggregate>
      

      Should be:

                  <aggregate strategyRef="bestQuote">
                      <correlationExpression>
                          <header id="loandId"/>
                      </correlationExpression>
                      <completionPredicate>
                          <simple>${header.CamelAggregatedCount} > 2</simple>
                      </completionPredicate>
                  </aggregate>
      

      So its in line with the correlation expression

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            Claus Ibsen
            Reporter:
            Claus Ibsen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development