Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-13785

can not user PulsarComponent

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Invalid
    • Affects Version/s: 3.0.0.M4
    • Fix Version/s: None
    • Component/s: camel-spring-boot
    • Labels:
      None
    • Environment:

      JDK8 + Gradle + IDEA + SpringBoot-2.1.4.RELEASE

    • Estimated Complexity:
      Unknown

      Description

      i try to use 'Apache Pulsar component' in springboot with gradle,

      but when i add the dependency of  'camel-pulsar-starter' like bellow:

      compile group: 'org.apache.camel', name: 'camel-pulsar-starter', version: '3.0.0.M4'

      the gradle gave me errors bellow:

      FAILURE:Build failed with an exception.

       * What went wrong:

      Could not resolve all files for configuration ':sa-common:compileClasspath'.

      > Could not resolve javax.xml.bind:activation:1.0.2.

        Required by:

            project :sa-common > org.apache.camel:camel-pulsar-starter:3.0.0-M4 > org.apache.camel:camel-pulsar:3.0.0-M4 > org.apache.pulsar:pulsar-client-admin:2.3.2

      so, how to solve this problem?

      thanks a lot.

       

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              cumtwwei wwei
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: