Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-13696

Upgrade to slf4j ver 1.7.26

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.23.4, 2.24.2, 3.0.0.M4, 3.0.0, 2.25.0
    • Component/s: None
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      Version 1.7.25 of slf4j contains a known vulnerability. Though this might not be easy to exploit, it results in application being flagged by monitoring tools. 

      Upgrade Camel, to use the latest patch version: 1.7.26

       

      For reference, see this Splunk JIRA: https://jira.qos.ch/browse/SLF4J-430

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                dariusx Darius Cooper
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 20m
                  20m