Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-12586

Use consistant Surefire and JAXB version

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.22.1
    • Component/s: build system
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      Seems that our daily build fails as the maven-surefire-plugin configured in JDK 9+ profile requires a version of jaxb-core that's no(t) (longer) available on Maven Central. And with SUREFIRE-1330 in 2.22.0 it opens the use of JUnit5 in Camel.

      Might be worth taking a look and use the same maven-surefire-plugin versions across all modules, some seem to be using version 2.19.1.

        Attachments

          Activity

            People

            • Assignee:
              zregvart Zoran Regvart
              Reporter:
              zregvart Zoran Regvart
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: