Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-10767

Versions of swagger-models and swagger-parser in conflict

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.19.0
    • Fix Version/s: 2.18.3, 2.19.0
    • Component/s: camel-swagger
    • Labels:
      None
    • Patch Info:
      Patch Available
    • Estimated Complexity:
      Unknown
    • Flags:
      Patch

      Description

      A change was made to swagger-modules in swagger-core#208335a08cae610d3b5eaea75f5552efaf15477b (version 1.5.12) that changed java.lang.Double type with java.math.BigDecimal which in turn made swager-parser incompatible in the version used (1.0.22).

      This was later fixed in swagger-parser swagger-parser#d7ac638f4355cc043a14dfcd244264aa1440c627 and released as version 1.0.25.

      Version of swagger-parser needs to be updated to 1.0.25.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                zregvart Zoran Regvart
                Reporter:
                zregvart Zoran Regvart
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: