Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-10764

The use of BrowserCompatHostnameVerifier is deprecated

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.19.0
    • Component/s: camel-http4
    • Labels:
      None
    • Patch Info:
      Patch Available
    • Estimated Complexity:
      Unknown
    • Flags:
      Patch

      Description

      The BrowserCompatHostnameVerifier has been deprecated in HttpClient
      version 4.4, instead DefaultHostnameVerifier should be used. The trunk of Apache HttpComponents, version 5.0 removes BrowserCompatHostnameVerifier, so this brings future compatibility to the component.

      The version of HttpClient needs to be upgraded to 4.5.3 because of HTTPCLIENT-1802.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                zregvart Zoran Regvart
                Reporter:
                zregvart Zoran Regvart
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: