Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-10367

remove extraneous dependency from camel-amqp module

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.17.3
    • Fix Version/s: 2.18.1, 2.19.0
    • Component/s: camel-amqp
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      I notice from http://camel.apache.org/amqp.html that camel-amqp is considered to support only AMQP 1.0 as of Camel 2.17.0. The camel-amqp module however in addition to its dependency on the newer Qpid AMQP 1.0 JMS client, continues to have a dependency on an old version of the Qpid AMQP 0-x JMS client. Since it isn't used anymore this dependency should be removed.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                davsclaus Claus Ibsen
                Reporter:
                robbie Robbie Gemmell
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: