Uploaded image for project: 'Calcite'
  1. Calcite
  2. CALCITE-608

Exception is thrown when RelMdDistribution for Project operator is called

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.1.0-incubating
    • Component/s: None
    • Labels:
      None

      Description

      The following Exception is thrown when the distribution metadata provider for Project is called:

      Caused by: java.lang.AssertionError
      at org.apache.calcite.util.mapping.Mappings.create(Mappings.java:62)
      at org.apache.calcite.rel.core.Project.getMapping(Project.java:283)
      at org.apache.calcite.rel.metadata.RelMdDistribution.project(RelMdDistribution.java:140)
      at org.apache.calcite.rel.metadata.RelMdDistribution.distribution(RelMdDistribution.java:87)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:606)
      at org.apache.calcite.rel.metadata.ReflectiveRelMetadataProvider$2$1.invoke(ReflectiveRelMetadataProvider.java:194)
      at com.sun.proxy.$Proxy31.distribution(Unknown Source)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      ...
      

      It looks like the assertion is too strict.

        Activity

        julianhyde Julian Hyde added a comment -

        Closing now that 1.1.0-incubating has been released.


          People

          • Assignee:
            jcamachorodriguez Jesus Camacho Rodriguez
            Reporter:
            jcamachorodriguez Jesus Camacho Rodriguez
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development