Uploaded image for project: 'Calcite'
  1. Calcite
  2. CALCITE-5037

Upgrade HSQLDB to 2.5.2

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • None
    • 1.31.0
    • None
    • None

    Description

      Upgrade HSQLDB to 2.5.2 (the last version that also supports Java 8) and allow people to run using HSQLDB 2.6.1 (the most recent version, which requires Java 11 or higher).

      We cannot currently do this because we depend on scott-data-hsqldb:0.1, foodmart-data-hsqldb:0.4 and chinook-data-hsqldb:0.1, and these have embedded data files in HSQLDB 1.8 format, which HSQLDB 2.5.1 no longer supports.

      Per HSQLDB's release notes:

      21 March 2021 - version 2.6.0
      ...
      – version 2.6.0 jar requires JRE 11 or later - tested up to Java 16 RC
      – version 2.6.0 alternative jar requires JRE 8 or later
      ...

      24 June 2020 - version 2.5.1
      version 2.5.1 jar requires JRE 8 or later - tested up to Java 14
      ...
      removed legacy support for opening version 1.8 databases

      I have released scott-data-hsqldb:0.2 and foodmart-data-hsqldb:0.5, and when we have chinook-data-hsqldb:0.2 we can upgrade to them and should be able to go to HSQLDB 2.5.1 or 2.6 (on Java 11, or on Java 8 with the alternative jar).

      Attachments

        Issue Links

          Activity

            People

              julianhyde Julian Hyde
              julianhyde Julian Hyde
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: