Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: avatica
    • Labels:
      None

      Description

      I am using the calcite-avatica hsqldb image here: https://hub.docker.com/r/f21global/calcite-avatica/

      The image is built using this docker file: https://github.com/apache/calcite-avatica/tree/master/docker/src/main/docker/hypersql

      I am currently running integration tests for the Go client against that image. It seems that after a certain amount of operations, the server will lock up. From the Go http client, it seems that avatica no longer responds. There wasn't any interesting information when I ran `docker logs` on the container avatica/hsqldb is running in.

      When it starts hanging, tests that were passing previously would fail randomly, because the test is not able to get a response form avatica. Usually, deleting and recreating the container would resolve the problem, but after using the same container through a few more test cycles, it starts to hang again.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                elserj Josh Elser
                Reporter:
                francischuang Francis Chuang
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated: