Uploaded image for project: 'Calcite'
  1. Calcite
  2. CALCITE-1597

Obsolete Util.newInternal and Throwables.propagate

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.12.0
    • Component/s: None
    • Labels:
      None

      Description

      Replace:

      • calls to Util.newInternal() with new AssertionError()
      • calls to Util.newInternal(message) with new AssertionError(message)
      • calls to Util.newInternal(message, ex) with either new AssertionError(message, ex) (if the problem is definitely a code bug) or new RuntimeException(message, ex) (if it is a user or system error)

      Also, remove calls to Throwables.propagate. It is deprecated as of Guava 20.

        Activity

        julianhyde Julian Hyde added a comment -

        Resolved in release 1.12.0 (2017-03-24).


          People

          • Assignee:
            julianhyde Julian Hyde
            Reporter:
            julianhyde Julian Hyde
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development