Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3
    • Fix Version/s: 1.4-beta1
    • Component/s: Framework
    • Labels:
      None
    • Environment:
      Operating System: Windows NT/2K
      Platform: PC

      Description

      Hi,
      I have just updated to Cactus 1.3 and the following code throws an exception
      :

      public class Testresults extends JspTestCase {
      ...
      protected void setUp() throws Exception

      { // Setup the needed beans // JSPDataConstants.initializeConstants(pageContext) ; SessionBean sessionBean = new SessionBean() ; pageContext.setAttribute("sessionBean", sessionBean,PageContext.SESSION_SCOPE) ; }

      ...
      java.lang.IllegalArgumentException: can't access SESSION_SCOPE without an
      HttpSession
      at
      org.apache.jasper.runtime.PageContextImpl.setAttribute(PageContextImpl.java:
      244)
      at
      org.apache.cactus.server.AbstractPageContextWrapper.dispatch63_setAttribute
      AbstractPageContextWrapper.java;org/apache/cactus/util/log/LogAspect.java(1k
      ):319)
      at
      org.apache.cactus.server.AbstractPageContextWrapper.around63_setAttribute(Ab
      stractPageContextWrapper.java;org/apache/cactus/util/log/LogAspect.java(1k):
      1147)
      at
      org.apache.cactus.server.AbstractPageContextWrapper.setAttribute(AbstractPag
      eContextWrapper.java;org/apache/cactus/util/log/LogAspect.java(1k):316)
      at Testresults.setUp(Testresults.java:86)
      at
      org.apache.cactus.AbstractTestCase.runBareServerTest(AbstractTestCase.java:4
      88)
      at
      org.apache.cactus.server.AbstractTestCaller.doTest(AbstractTestCaller.java:1
      48)
      ...

      It worked with Cactus previous version, but I remember I had to change the
      jspRedirector.jsp first line to
      <%@page import="org.apache.cactus.server.*" session="true" %> (the original
      version states session="false")

      I made this change because I had a similar exception and saw this advice on
      cactus mailing list.

        Activity

        Vincent Massol added a comment -

        Thanks Marc. Fixed in Cactus 1.4dev.

        Vincent Massol added a comment -
            • Bug 9785 has been marked as a duplicate of this bug. ***

          People

          • Assignee:
            Vincent Massol
            Reporter:
            Marc Brette
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development