Buildr
  1. Buildr
  2. BUILDR-137

JRuby 1.1.3 and Buildr 1.3.2 don't appear to work (on Windows)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.3.2
    • Fix Version/s: 1.3.3
    • Component/s: JRuby
    • Labels:
      None
    • Environment:
      Windows Vista, Buildr 1.3.2 (via gem install), JRuby 1.1.3, JDK 1.6.0_02

      Description

      This occurs after a fresh install...

      C:\temp>buildr --version
      C:/Program Files/Java/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require': no such file to load – dl/import (LoadError)
      from C:/Program Files/Java/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
      from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/pageant.rb:1
      from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/pageant.rb:27:in `require'
      from C:/Program Files/Java/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
      from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/agent.rb:6
      from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/agent.rb:27:in `require'
      from C:/Program Files/Java/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
      from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/key_manager.rb:4
      ... 20 levels...
      from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/buildr-1.3.2-java/bin/buildr:19
      from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/buildr-1.3.2-java/bin/buildr:19:in `load'
      from C:\Program Files\Java\jruby-1.1.3\bin\buildr:19

        Issue Links

          Activity

          Assaf Arkin made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Assaf Arkin made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Assaf Arkin added a comment -

          Applied fix which works for me (XP, Cygwin, JRuby 1.1.4).

          Assaf Arkin added a comment -

          Is this issue still present in trunk/head?

          Assaf Arkin made changes -
          Fix Version/s 1.3.3 [ 12313289 ]
          Assaf Arkin added a comment -

          The problem is actually with Net::SSH, and it will consistently fail whichever version of JRuby you use because it incorrectly detects the platform.

          Any ideas on how we can get it tested so it doesn't break again?

          Kelly Harward made changes -
          Summary JRuby 1.1.3 and Buildr 1.3.2 don't appear to work JRuby 1.1.3 and Buildr 1.3.2 don't appear to work (on Windows)
          Kelly Harward made changes -
          Environment Windows XP, Buildr 1.3.2 (via gem install), JRuby 1.1.3, JDK 1.6.0_02 Windows Vista, Buildr 1.3.2 (via gem install), JRuby 1.1.3, JDK 1.6.0_02
          Kelly Harward added a comment -

          Appears to be the same issue as BUILDR-82. Since that issue has been resolved as fixed and the environment in which I am seeing the issue is different than the one described there, I cloned that issue rather than attempting to reopen it.

          Kelly Harward made changes -
          Fix Version/s 1.3.2 [ 12313159 ]
          Environment Windows XP, Buildr 1.3.1.1 (via gem install), JDK 1.6.0_06 Windows XP, Buildr 1.3.2 (via gem install), JRuby 1.1.3, JDK 1.6.0_02
          Affects Version/s 1.3.1 [ 12312952 ]
          Description This occurs after a fresh install...

          C:\Documents and Settings\Shane>jruby -S buildr
          C:/jruby-1.1.2/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
          : no such file to load -- dl/import (LoadError)
                  from C:/jruby-1.1.2/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27
          :in `require'
                  from C:/jruby-1.1.2/lib/ruby/gems/1.8/gems/net-ssh-2.0.1/lib/net/ssh/aut
          hentication/pageant.rb:1:in `C:/jruby-1.1.2/lib/ruby/gems/1.8/gems/net-ssh-2.0.1
          /lib/net/ssh/authentication/pageant.rb'
                  from C:/jruby-1.1.2/lib/ruby/gems/1.8/gems/net-ssh-2.0.1/lib/net/ssh/aut
          hentication/pageant.rb:27:in `require'
                  from C:/jruby-1.1.2/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27
          :in `require'
                  from C:/jruby-1.1.2/lib/ruby/gems/1.8/gems/net-ssh-2.0.1/lib/net/ssh/aut
          hentication/agent.rb:6:in `C:/jruby-1.1.2/lib/ruby/gems/1.8/gems/net-ssh-2.0.1/l
          ib/net/ssh/authentication/agent.rb'
                  from C:/jruby-1.1.2/lib/ruby/gems/1.8/gems/net-ssh-2.0.1/lib/net/ssh/aut
          hentication/agent.rb:27:in `require'
                  from C:/jruby-1.1.2/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27
          :in `require'
                  from C:/jruby-1.1.2/lib/ruby/gems/1.8/gems/net-ssh-2.0.1/lib/net/ssh/aut
          hentication/key_manager.rb:4:in `C:/jruby-1.1.2/lib/ruby/gems/1.8/gems/net-ssh-2
          .0.1/lib/net/ssh/authentication/key_manager.rb'
                   ... 11 levels...
                  from C:/jruby-1.1.2/lib/ruby/gems/1.8/gems/buildr-1.3.1.1-java/bin/build
          r:19:in `C:/jruby-1.1.2/lib/ruby/gems/1.8/gems/buildr-1.3.1.1-java/bin/buildr'
                  from C:/jruby-1.1.2/lib/ruby/gems/1.8/gems/buildr-1.3.1.1-java/bin/build
          r:19:in `load'
                  from C:/jruby-1.1.2/bin/buildr:19
          This occurs after a fresh install...

          C:\temp>buildr --version
          C:/Program Files/Java/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require': no such file to load -- dl/import (LoadError)
                  from C:/Program Files/Java/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
                  from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/pageant.rb:1
                  from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/pageant.rb:27:in `require'
                  from C:/Program Files/Java/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
                  from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/agent.rb:6
                  from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/agent.rb:27:in `require'
                  from C:/Program Files/Java/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
                  from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/key_manager.rb:4
                   ... 20 levels...
                  from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/buildr-1.3.2-java/bin/buildr:19
                  from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/buildr-1.3.2-java/bin/buildr:19:in `load'
                  from C:\Program Files\Java\jruby-1.1.3\bin\buildr:19
          Affects Version/s 1.3.2 [ 12313159 ]
          Kelly Harward made changes -
          Field Original Value New Value
          Link This issue is a clone of BUILDR-82 [ BUILDR-82 ]
          Kelly Harward created issue -

            People

            • Assignee:
              Unassigned
              Reporter:
              Kelly Harward
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development