Uploaded image for project: 'Bookkeeper'
  1. Bookkeeper
  2. BOOKKEEPER-60

confusion between multiple "consume" methods

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: hedwig-client
    • Labels:
      None

      Description

      There are currently 2 methods named "consume" in the client API:

      • in org.apache.hedwig.client.api.MessageHandler : delegates the processing of a message by a message handler
      • in org.apache.hedwig.client.api.Subscriber : notifies the server that messages have been processed till a given sequence id. This is some kind of acknowledgement.

      I don't think these 2 fundamental methods should be named the same: they have different purposes and it is confusing.

      Couldn't we rename Subscriber.consume into Subscriber.acknowledge, or something similar?

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              mmorel Matthieu Morel

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment