Apache Blur
  1. Apache Blur
  2. BLUR-299

Custom types at the system/cluster level aren't registered when the OutputFormat creates the table.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.3.0, 0.2.1, 0.2.2
    • Fix Version/s: 0.3.0, 0.2.2
    • Component/s: None
    • Labels:
      None

      Description

      Reproduce by adding a custom field type via blur-site.properties; then use M/R to create a new table that utilizes that field definition. It fails because of an unknown type.

        Activity

        Tim Williams created issue -
        Hide
        Garrett Barton added a comment -

        I've been running into this too. Broken in 0.2.1 as well.

        Show
        Garrett Barton added a comment - I've been running into this too. Broken in 0.2.1 as well.
        Aaron McCurry made changes -
        Field Original Value New Value
        Affects Version/s 0.3.0 [ 12324336 ]
        Affects Version/s 0.2.1 [ 12325046 ]
        Affects Version/s 0.2.2 [ 12325596 ]
        Affects Version/s 0.2.0 [ 12324255 ]
        Aaron McCurry made changes -
        Fix Version/s 0.3.0 [ 12324336 ]
        Fix Version/s 0.2.2 [ 12325596 ]
        Show
        Aaron McCurry added a comment - https://git-wip-us.apache.org/repos/asf?p=incubator-blur.git;a=commit;h=0e91346dcb55ebe81edffd768d22e6cd6fe7c567 https://git-wip-us.apache.org/repos/asf?p=incubator-blur.git;a=commit;h=1266c81699a8e4025bce2e45148189a15f5f6b86
        Aaron McCurry made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Tim Williams
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development