Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-680

Write util function to capture test input parameters

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 0.4.0
    • Fix Version/s: 0.5.0
    • Component/s: tests
    • Labels:
      None

      Description

      We don't have a standardized way of capturing the test input parameters. We usually grab the inputs by making System.getProperty calls. If someone strays from using System.getProperty, it makes it hard to grep for the test inputs. We should wrap this logic in a util function.

        Activity

        schu Stephen Chu added a comment -

        This is a duplicate of BIGTOP-685. Can someone close this for me?

        bmahe Bruno Mahé added a comment -

        Stephen, as a commiter you should have the permission to close tickets.
        I will close this ticket and look at your permissions.

        schu Stephen Chu added a comment -

        Thanks, Bruno. Yeah, I couldn't find the close button.


          People

          • Assignee:
            schu Stephen Chu
            Reporter:
            schu Stephen Chu
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development