Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.2.0
    • Fix Version/s: 0.2.0
    • Component/s: General
    • Labels:
      None

      Description

      Not sure if this is because of whirr moving from the incubator to a TLP, but the url used to download its source tarball is invalid.

      http://apache.osuosl.org//incubator/whirr/whirr-0.5.0-incubating//whirr-0.5.0-incubating-src.tar.gz does not point to anything (anymore)

      1. BIGTOP-47.diff
        0.8 kB
        Andrew Bayer

        Activity

        Roman Shaposhnik made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Gavin made changes -
        Workflow no-reopen-closed, patch-avail [ 12631069 ] patch-available, re-open possible [ 12666208 ]
        Mark Thomas made changes -
        Workflow jira [ 12630242 ] no-reopen-closed, patch-avail [ 12631069 ]
        Andrew Bayer made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Hide
        Bruno Mahé added a comment -

        I am also against any update of BigTop components until we get some tests going on.

        Show
        Bruno Mahé added a comment - I am also against any update of BigTop components until we get some tests going on.
        Andrew Bayer made changes -
        Fix Version/s 0.2.0 [ 12317591 ]
        Hide
        Roman Shaposhnik added a comment -

        +1

        Show
        Roman Shaposhnik added a comment - +1
        Andrew Bayer made changes -
        Attachment BIGTOP-47.diff [ 12492103 ]
        Hide
        Andrew Bayer added a comment -

        Patch switches whirr to download from archive.apache.org, so that we can keep using 0.5.0 for now.

        Show
        Andrew Bayer added a comment - Patch switches whirr to download from archive.apache.org, so that we can keep using 0.5.0 for now.
        Andrew Bayer made changes -
        Field Original Value New Value
        Assignee Andrew Bayer [ abayer ]
        Hide
        Andrew Bayer added a comment -

        Ah-ha. https://github.com/apache/whirr/commit/630e029d6e35cb93e9ea58ee11f926da6da064b7 is the problem - in the Debian build, some files are generated at build-time (debian/build.properties, debian/compat, patch-stamp) which have no license in them, and so rat is barfing. Looks like we will have to stick with 0.5.0-incubating for now, at least until a new release of whirr covers these files as exclusions from rat.

        Show
        Andrew Bayer added a comment - Ah-ha. https://github.com/apache/whirr/commit/630e029d6e35cb93e9ea58ee11f926da6da064b7 is the problem - in the Debian build, some files are generated at build-time (debian/build.properties, debian/compat, patch-stamp) which have no license in them, and so rat is barfing. Looks like we will have to stick with 0.5.0-incubating for now, at least until a new release of whirr covers these files as exclusions from rat.
        Hide
        Andrew Bayer added a comment -

        Huh. I can't get 0.6.0 to build on Debian - it's barfing in the top-level project, with this error: "[ERROR] Failed to execute goal org.apache.rat:apache-rat-plugin:0.7:check (default) on project whirr: Too many unapproved licenses: 3 -> [Help 1]". What's really weird is that I can build on a CentOS box no problem.

        Show
        Andrew Bayer added a comment - Huh. I can't get 0.6.0 to build on Debian - it's barfing in the top-level project, with this error: " [ERROR] Failed to execute goal org.apache.rat:apache-rat-plugin:0.7:check (default) on project whirr: Too many unapproved licenses: 3 -> [Help 1] ". What's really weird is that I can build on a CentOS box no problem.
        Hide
        Andrew Bayer added a comment -

        True. For now, we should be ok updating to 0.6.0.

        Show
        Andrew Bayer added a comment - True. For now, we should be ok updating to 0.6.0.
        Hide
        Bruno Mahé added a comment -

        We test them?
        But this discussion should be happening on the ml.

        Here it's just about finding a working mirror of apache archive for whirr.

        Show
        Bruno Mahé added a comment - We test them? But this discussion should be happening on the ml. Here it's just about finding a working mirror of apache archive for whirr.
        Hide
        Andrew Bayer added a comment -

        This does raise a bigger question - how do we decide what version of the component projects will be used? How do we decide to change that?

        Show
        Andrew Bayer added a comment - This does raise a bigger question - how do we decide what version of the component projects will be used? How do we decide to change that?
        Hide
        Andrei Savu added a comment -

        The previous versions are still available here: http://archive.apache.org/dist//incubator/whirr/

        Show
        Andrei Savu added a comment - The previous versions are still available here: http://archive.apache.org/dist//incubator/whirr/
        Hide
        Bruno Mahé added a comment -

        So the issue is whirr has released a newer version and the 0.5.0 bits has been archived.

        Show
        Bruno Mahé added a comment - So the issue is whirr has released a newer version and the 0.5.0 bits has been archived.
        Bruno Mahé created issue -

          People

          • Assignee:
            Andrew Bayer
            Reporter:
            Bruno Mahé
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development