Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-3653

Building Kibana fails due to the npm error

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Blocker
    • Resolution: Fixed
    • None
    • 3.1.0, 3.0.1
    • None
    • None

    Description

      https://ci.bigtop.apache.org/job/Bigtop-3.0.1/7/DISTRO=centos-8,PLATFORM=aarch64-slave/console
      https://ci.bigtop.apache.org/job/Bigtop-3.0.1/7/DISTRO=debian-9,PLATFORM=aarch64-slave/console
      https://ci.bigtop.apache.org/job/Bigtop-3.0.1/7/DISTRO=debian-10,PLATFORM=aarch64-slave/console
      https://ci.bigtop.apache.org/job/Bigtop-3.0.1/7/DISTRO=ubuntu-18.04,PLATFORM=aarch64-slave/console
      https://ci.bigtop.apache.org/job/Bigtop-3.0.1/7/DISTRO=ubuntu-20.04,PLATFORM=aarch64-slave/console
      https://ci.bigtop.apache.org/job/Bigtop-3.0.1/7/DISTRO=debian-9,PLATFORM=amd64-slave/console
      https://ci.bigtop.apache.org/job/Bigtop-3.0.1/7/DISTRO=debian-10,PLATFORM=amd64-slave/console

      npm ERR! git submodule -q update --init --recursive: fatal: remote error: 
      npm ERR! git submodule -q update --init --recursive:   The unauthenticated git protocol on port 9418 is no longer supported.
      npm ERR! git submodule -q update --init --recursive: Please see https://github.blog/2021-09-01-improving-git-protocol-security-github/ for more information.
      npm ERR! git submodule -q update --init --recursive: fatal: clone of 'git://github.com/jquery/sizzle.git' into submodule path '/tmp/npm-763-1b9c379f/git-cache-c74acfcd/f852e631ba85af7da4ad7594785e122504e7b233/src/sizzle' failed
      npm ERR! git submodule -q update --init --recursive: Failed to clone 'src/sizzle'. Retry scheduled
      npm ERR! git submodule -q update --init --recursive: fatal: remote error: 
      npm ERR! git submodule -q update --init --recursive:   The unauthenticated git protocol on port 9418 is no longer supported.
      npm ERR! git submodule -q update --init --recursive: Please see https://github.blog/2021-09-01-improving-git-protocol-security-github/ for more information.
      npm ERR! git submodule -q update --init --recursive: fatal: clone of 'git://github.com/jquery/qunit.git' into submodule path '/tmp/npm-763-1b9c379f/git-cache-c74acfcd/f852e631ba85af7da4ad7594785e122504e7b233/test/qunit' failed
      npm ERR! git submodule -q update --init --recursive: Failed to clone 'test/qunit'. Retry scheduled
      npm ERR! git submodule -q update --init --recursive: fatal: remote error: 
      npm ERR! git submodule -q update --init --recursive:   The unauthenticated git protocol on port 9418 is no longer supported.
      npm ERR! git submodule -q update --init --recursive: Please see https://github.blog/2021-09-01-improving-git-protocol-security-github/ for more information.
      npm ERR! git submodule -q update --init --recursive: fatal: clone of 'git://github.com/jquery/qunit.git' into submodule path '/tmp/npm-763-1b9c379f/git-cache-c74acfcd/f852e631ba85af7da4ad7594785e122504e7b233/test/qunit' failed
      npm ERR! git submodule -q update --init --recursive: Failed to clone 'test/qunit' a second time, aborting
      npm ERR! git submodule -q update --init --recursive: fatal: remote error: 
      npm ERR! git submodule -q update --init --recursive:   The unauthenticated git protocol on port 9418 is no longer supported.
      npm ERR! git submodule -q update --init --recursive: Please see https://github.blog/2021-09-01-improving-git-protocol-security-github/ for more information.
      npm ERR! git submodule -q update --init --recursive: fatal: clone of 'git://github.com/jquery/sizzle.git' into submodule path '/tmp/npm-763-1b9c379f/git-cache-c74acfcd/f852e631ba85af7da4ad7594785e122504e7b233/src/sizzle' failed
      npm ERR! git submodule -q update --init --recursive: Failed to clone 'src/sizzle' a second time, aborting
      npm ERR! git submodule -q update --init --recursive: 
      npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules/chokidar/node_modules/fsevents):
      npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
      npm ERR! Linux 5.10.82-83.359.amzn2.x86_64
      npm ERR! argv "/var/lib/jenkins/.nvm/versions/node/v6.10.2/bin/node" "/var/lib/jenkins/.nvm/versions/node/v6.10.2/bin/npm" "install"
      npm ERR! node v6.10.2
      npm ERR! npm  v3.10.10
      npm ERR! code 1
      
      npm ERR! Command failed: git submodule -q update --init --recursive
      npm ERR! fatal: remote error: 
      npm ERR!   The unauthenticated git protocol on port 9418 is no longer supported.
      npm ERR! Please see https://github.blog/2021-09-01-improving-git-protocol-security-github/ for more information.
      npm ERR! fatal: clone of 'git://github.com/jquery/sizzle.git' into submodule path '/tmp/npm-763-1b9c379f/git-cache-c74acfcd/f852e631ba85af7da4ad7594785e122504e7b233/src/sizzle' failed
      npm ERR! Failed to clone 'src/sizzle'. Retry scheduled
      npm ERR! fatal: remote error: 
      npm ERR!   The unauthenticated git protocol on port 9418 is no longer supported.
      npm ERR! Please see https://github.blog/2021-09-01-improving-git-protocol-security-github/ for more information.
      npm ERR! fatal: clone of 'git://github.com/jquery/qunit.git' into submodule path '/tmp/npm-763-1b9c379f/git-cache-c74acfcd/f852e631ba85af7da4ad7594785e122504e7b233/test/qunit' failed
      npm ERR! Failed to clone 'test/qunit'. Retry scheduled
      npm ERR! fatal: remote error: 
      npm ERR!   The unauthenticated git protocol on port 9418 is no longer supported.
      npm ERR! Please see https://github.blog/2021-09-01-improving-git-protocol-security-github/ for more information.
      npm ERR! fatal: clone of 'git://github.com/jquery/qunit.git' into submodule path '/tmp/npm-763-1b9c379f/git-cache-c74acfcd/f852e631ba85af7da4ad7594785e122504e7b233/test/qunit' failed
      npm ERR! Failed to clone 'test/qunit' a second time, aborting
      npm ERR! fatal: remote error: 
      npm ERR!   The unauthenticated git protocol on port 9418 is no longer supported.
      npm ERR! Please see https://github.blog/2021-09-01-improving-git-protocol-security-github/ for more information.
      npm ERR! fatal: clone of 'git://github.com/jquery/sizzle.git' into submodule path '/tmp/npm-763-1b9c379f/git-cache-c74acfcd/f852e631ba85af7da4ad7594785e122504e7b233/src/sizzle' failed
      npm ERR! Failed to clone 'src/sizzle' a second time, aborting
      npm ERR! 
      npm ERR! 
      npm ERR! If you need help, you may report this error at:
      npm ERR!     <https://github.com/npm/npm/issues>
      
      npm ERR! Please include the following file with any support request:
      npm ERR!     /ws/output/kibana/kibana-5.4.1/npm-debug.log
      make[1]: *** [debian/rules:30: override_dh_auto_build] Error 1
      make[1]: Leaving directory '/ws/output/kibana/kibana-5.4.1'
      make: *** [debian/rules:27: build] Error 2
      debuild: fatal error at line 1182:
      dpkg-buildpackage -us -uc -ui -bdpkg-buildpackage: error: debian/rules build subprocess returned exit status 2
      
       failed
      
      > Task :kibana-deb FAILED
      

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            sekikn Kengo Seki
            sekikn Kengo Seki
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 0.5h
                0.5h

                Slack

                  Issue deployment