Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-3551

Phantomjs caused Ambari build failure on non-x86

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.0
    • Component/s: build
    • Labels:
      None

      Description

      After ambari is bumped to 2.7.5, it cannot build on non-x86 platforms as phantomjs prebuilt is required.

      [^[[1;34mINFO^[[m] Running 'yarn install --ignore-engines --pure-lockfile' in /var/lib/jenkins/bigtop/output/ambari/ambari-2.7.5.0/ambari-web
      [^[[1;34mINFO^[[m] yarn install v0.23.2
      [^[[1;31mERROR^[[m] warning Ambari@2.4.0: No license field
      [^[[1;34mINFO^[[m] [1/4] Resolving packages...
      [^[[1;34mINFO^[[m] [2/4] Fetching packages...
      [^[[1;31mERROR^[[m] warning fsevents@0.3.8: The platform "linux" is incompatible with this module.
      [^[[1;34mINFO^[[m] info "fsevents@0.3.8" is an optional dependency and failed compatibility check. Excluding it from installation.
      [^[[1;31mERROR^[[m] warning fsevents@1.1.1: The platform "linux" is incompatible with this module.
      [^[[1;34mINFO^[[m] info "fsevents@1.1.1" is an optional dependency and failed compatibility check. Excluding it from installation.
      [^[[1;34mINFO^[[m] [3/4] Linking dependencies...
      [^[[1;34mINFO^[[m] [4/4] Building fresh packages...
      [^[[1;31mERROR^[[m] error /var/lib/jenkins/bigtop/output/ambari/ambari-2.7.5.0/ambari-web/node_modules/phantomjs-prebuilt: Command failed.
      [^[[1;31mERROR^[[m] Exit code: 1
      [^[[1;31mERROR^[[m] Command: sh
      [^[[1;34mINFO^[[m] info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
      [^[[1;31mERROR^[[m] Arguments: -c node install.js
      [^[[1;31mERROR^[[m] Directory: /var/lib/jenkins/bigtop/output/ambari/ambari-2.7.5.0/ambari-web/node_modules/phantomjs-prebuilt
      [^[[1;31mERROR^[[m] Output:
      [^[[1;31mERROR^[[m] PhantomJS not found on PATH
      [^[[1;31mERROR^[[m] Unexpected platform or architecture: linux/arm64
      [^[[1;31mERROR^[[m] It seems there is no binary available for your platform/architecture
      [^[[1;31mERROR^[[m] Try to install PhantomJS globally 

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jun.he Jun He
                Reporter:
                jun.he Jun He
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 0.5h
                  0.5h