Bigtop
  1. Bigtop
  2. BIGTOP-3

gitignore files need to be removed from SVN

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: 0.2.0
    • Component/s: general
    • Labels:
      None

      Description

      When I imported the source, I forgot to remove .gitignore files, so we've got a bunch of them sitting around. I need to prune those out.

      1. gitignore.diff
        0.1 kB
        Andrew Bayer
      2. BIGTOP-3.txt
        3 kB
        Jolly Chen

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open In Progress In Progress
        77d 21h 1m 1 Andrew Bayer 18/Oct/11 20:09
        In Progress In Progress Resolved Resolved
        6s 1 Andrew Bayer 18/Oct/11 20:09
        Resolved Resolved Closed Closed
        251d 20h 48m 1 Roman Shaposhnik 26/Jun/12 16:57
        Roman Shaposhnik made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Gavin made changes -
        Workflow no-reopen-closed, patch-avail [ 12631057 ] patch-available, re-open possible [ 12666174 ]
        Andrew Bayer made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Resolution Won't Fix [ 2 ]
        Andrew Bayer made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Roman Shaposhnik added a comment -

        I'm inclined to close this, even though we still .gitignore all over the place. Thoughts?

        Konstantin Boudnik added a comment -

        Looks like it has been committed. Shall the ticket be closed?

        Mark Thomas made changes -
        Workflow jira [ 12624255 ] no-reopen-closed, patch-avail [ 12631057 ]
        Andrew Bayer made changes -
        Fix Version/s 0.2.0 [ 12317591 ]
        Fix Version/s 0.1.0 [ 12317549 ]
        Andrew Bayer added a comment -

        gitignore committed.

        Peter Linnell added a comment -

        +1 for gitignore.diff

        svn:ignore sounds fine as well

        Bruno Mahé added a comment -

        +1 for gitignore.diff

        Andrew Bayer made changes -
        Attachment gitignore.diff [ 12489223 ]
        Andrew Bayer added a comment -

        I'm going to leave them be, but I am going to add a top-level .gitignore (and svn:ignore attributes as well).

        Bruno Mahé added a comment - - edited

        a bunch of .gitignore files strewn around the various rpm-related directories, which don't actually help anything so far as I can tell

        The build system was/is/may expect some of these directories to exist. So the .gitignore trick would force the directories to be preserved in git, even if empty. I am not sure if this is still needed though.
        I will take a look, although I suspect this may be needed by rpmbuild itself.

        Andrew Bayer made changes -
        Fix Version/s 0.1.0 [ 12317549 ]
        Component/s General [ 12315313 ]
        Andrew Bayer added a comment -

        On further examination, the issue is that there are a bunch of .gitignore files strewn around the various rpm-related directories, which don't actually help anything so far as I can tell. I'll add a top level .gitignore, and remove all the superfluous ones.

        Andrei Savu added a comment -

        I suggest we keep them. Personally I do all development using git and only commit patches using svn.

        Andrew Bayer added a comment -

        Aaaah, good point. I hadn't thought of that. I'll leave this in limbo for a bit while we think about that.

        Owen O'Malley added a comment -

        Actually, many of the Apache projects have gitignore files because many of the developers use git.apache.org for read-only access to the projects.

        Jolly Chen added a comment -

        Patch submitted.

        Jolly Chen made changes -
        Field Original Value New Value
        Attachment BIGTOP-3.txt [ 12488473 ]
        Andrew Bayer created issue -

          People

          • Assignee:
            Andrew Bayer
            Reporter:
            Andrew Bayer
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development