Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-2900

Crunch build failed because of OS OOM killer on OpenJDK 1.8.0-144

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.2.0
    • Fix Version/s: 1.2.1
    • Component/s: build
    • Labels:
      None

      Description

      According to our CI, the 1.2.1 release is blocked by Crunch build failed on CentOS 7.

        Issue Links

          Activity

          evans_ye Evans Ye added a comment -

          The problem is related to OpenJDK 1.8.0-144.
          Since Bigtop master packaging matrix is build against trunk docker images, which are built long time ago, therefore the JDK minor versions are quite old. That's why Crunch build is OK in master, but failed in 1.2 branch.

          If we downgrade JDK to 1.8.0-131 on CentOS 7, then Crunch build succeed. Increasing heap does not help since I've tried 8192m.
          Although there's no clear root cause found, we can at least proceed with a workaround.

          githubbot ASF GitHub Bot added a comment -

          GitHub user evans-ye opened a pull request:

          https://github.com/apache/bigtop/pull/296

          BIGTOP-2900 Crunch build failed because of OS OOM killer on OpenJDK 1.8.0-144

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/evans-ye/bigtop BIGTOP-2900

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/bigtop/pull/296.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #296


          commit 0e27717ce833f717b595537eac0816faba17856a
          Author: Evans Ye <evansye@apache.org>
          Date: 2017-10-03T13:48:55Z

          BIGTOP-2900 Crunch build failed because of OS OOM killer on OpenJDK 1.8.0-144


          oflebbe Olaf Flebbe added a comment -

          if this actually helps to get the release out of the door: LGTM +1

          evans_ye Evans Ye added a comment -

          Committed to branch 1.2.
          Since this is for sure an workaround. We should come up a better solution in master. Let's have this in 1.2.1 only.

          evans_ye Evans Ye added a comment - - edited

          Turns out that Fedora 25 is also failing since the newly built docker images has OpenJDK 1.8.0-144 installed.
          I've updated the patch and pushed to branch 1.2 to fix it.


            People

            • Assignee:
              evans_ye Evans Ye
              Reporter:
              evans_ye Evans Ye
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development