Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-2864

Tez with "Class path contains multiple SLF4J bindings" warnings

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.2.0
    • Fix Version/s: 1.3.0
    • Component/s: debian, rpm, tez
    • Labels:
      None

      Description

      When using Tez, there will be "Class path contains multiple SLF4J bindings" warnings. This caused by existence of 'slf4j-log4j12-*.jar' in tez lib.
      The same issue resolved before.
      https://issues.apache.org/jira/browse/BIGTOP-583

        Issue Links

          Activity

          githubbot ASF GitHub Bot added a comment -

          Github user loleek commented on the issue:

          https://github.com/apache/bigtop/pull/272

          Yes, there is one in hadoop.

          cos Konstantin Boudnik added a comment -

          Committed, thanks!

          githubbot ASF GitHub Bot added a comment -

          Github user asfgit closed the pull request at:

          https://github.com/apache/bigtop/pull/272

          githubbot ASF GitHub Bot added a comment -

          Github user c0s commented on the issue:

          https://github.com/apache/bigtop/pull/272

          So, I assume the one from Hadoop will be used instead, right?
          Looks reasonable, I will commit this shortly.

          githubbot ASF GitHub Bot added a comment -

          GitHub user loleek opened a pull request:

          https://github.com/apache/bigtop/pull/272

          BIGTOP-2864:Multiple SLF4J bindings in tez

          When using Tez, there will be "Class path contains multiple SLF4J bindings" warnings. This caused by existence of 'slf4j-log4j12-*.jar' in tez lib.
          The same issue resolved before.
          Reference : https://issues.apache.org/jira/browse/BIGTOP-583

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/loleek/bigtop master

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/bigtop/pull/272.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #272


          commit e11539cef996b3ddf35e5bb0c833883a99bd7815
          Author: dengkai02 <dengkai02@baidu.com>
          Date: 2017-08-04T06:20:13Z

          BIGTOP-2864:Multiple SLF4J bindings in tez



            People

            • Assignee:
              lolee_k dengkai
              Reporter:
              lolee_k dengkai
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development