Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-2842

Zeppelin rpm is broken on CentOS 7

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 1.2.0
    • Fix Version/s: None
    • Component/s: rpm
    • Labels:
      None

      Description

      # yum install zeppelin
      ......
      
      --> Running transaction check
      ---> Package zeppelin.noarch 0:0.7.2-1.el7.centos will be installed
      --> Processing Dependency: osgi(org.eclipse.text) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.eclipse.core.runtime) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.eclipse.core.resources) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-tx) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-jdbc) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-expression) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-core) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-context-support) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-context) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-beans) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(com.jcraft.jsch) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Running transaction check
      ---> Package jsch.noarch 0:0.1.50-5.el7 will be installed
      --> Processing Dependency: jzlib >= 1.0.5 for package: jsch-0.1.50-5.el7.noarch
      --> Processing Dependency: jpackage-utils for package: jsch-0.1.50-5.el7.noarch
      ---> Package zeppelin.noarch 0:0.7.2-1.el7.centos will be installed
      --> Processing Dependency: osgi(org.eclipse.text) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.eclipse.core.runtime) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.eclipse.core.resources) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-tx) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-jdbc) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-expression) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-core) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-context-support) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-context) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-beans) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Running transaction check
      ---> Package javapackages-tools.noarch 0:3.4.1-11.el7 will be installed
      --> Processing Dependency: python-javapackages = 3.4.1-11.el7 for package: javapackages-tools-3.4.1-11.el7.noarch
      ---> Package jzlib.noarch 0:1.1.1-6.el7 will be installed
      ---> Package zeppelin.noarch 0:0.7.2-1.el7.centos will be installed
      --> Processing Dependency: osgi(org.eclipse.text) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.eclipse.core.runtime) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.eclipse.core.resources) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-tx) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-jdbc) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-expression) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-core) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-context-support) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-context) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-beans) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Running transaction check
      ---> Package python-javapackages.noarch 0:3.4.1-11.el7 will be installed
      ---> Package zeppelin.noarch 0:0.7.2-1.el7.centos will be installed
      --> Processing Dependency: osgi(org.eclipse.text) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.eclipse.core.runtime) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.eclipse.core.resources) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-tx) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-jdbc) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-expression) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-core) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-context-support) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-context) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Processing Dependency: osgi(org.apache.servicemix.bundles.spring-beans) for package: zeppelin-0.7.2-1.el7.centos.noarch
      --> Finished Dependency Resolution
      Error: Package: zeppelin-0.7.2-1.el7.centos.noarch (myrepo)
                 Requires: osgi(org.apache.servicemix.bundles.spring-tx)
      Error: Package: zeppelin-0.7.2-1.el7.centos.noarch (myrepo)
                 Requires: osgi(org.apache.servicemix.bundles.spring-jdbc)
      Error: Package: zeppelin-0.7.2-1.el7.centos.noarch (myrepo)
                 Requires: osgi(org.eclipse.core.resources)
      Error: Package: zeppelin-0.7.2-1.el7.centos.noarch (myrepo)
                 Requires: osgi(org.apache.servicemix.bundles.spring-context)
      Error: Package: zeppelin-0.7.2-1.el7.centos.noarch (myrepo)
                 Requires: osgi(org.eclipse.text)
      Error: Package: zeppelin-0.7.2-1.el7.centos.noarch (myrepo)
                 Requires: osgi(org.eclipse.core.runtime)
      Error: Package: zeppelin-0.7.2-1.el7.centos.noarch (myrepo)
                 Requires: osgi(org.apache.servicemix.bundles.spring-context-support)
      Error: Package: zeppelin-0.7.2-1.el7.centos.noarch (myrepo)
                 Requires: osgi(org.apache.servicemix.bundles.spring-beans)
      Error: Package: zeppelin-0.7.2-1.el7.centos.noarch (myrepo)
                 Requires: osgi(org.apache.servicemix.bundles.spring-expression)
      Error: Package: zeppelin-0.7.2-1.el7.centos.noarch (myrepo)
                 Requires: osgi(org.apache.servicemix.bundles.spring-core)
       You could try using --skip-broken to work around the problem
      
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                warwithin YoungWoo Kim
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: