Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-2557

BIGTOP-2536 broke DataFu, QFS and YCSB

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.0
    • Fix Version/s: 1.2.0
    • Component/s: build
    • Labels:
      None

      Description

      Follow-up issue from BIGTOP-2536.

        Issue Links

          Activity

          cos Konstantin Boudnik added a comment -

          Committed and pushed. Thanks Kengo Seki

          cos Konstantin Boudnik added a comment -

          Ok, fair enough... I will commit it and will see what CI produces

          sekikn Kengo Seki added a comment -

          Hmm, I didn't see such error. In my environment (Ubuntu 16.04, not docker image) ./gradlew ycsb-deb succeeded as follows:

          [INFO] Tarantool DB Binding ............................... SUCCESS [  0.685 s]
          [INFO] YCSB Release Distribution Builder .................. SUCCESS [ 16.870 s]
          [INFO] ------------------------------------------------------------------------
          [INFO] BUILD SUCCESS
          [INFO] ------------------------------------------------------------------------
          [INFO] Total time: 01:13 min
          [INFO] Finished at: 2016-10-25T23:33:34+09:00
          [INFO] Final Memory: 96M/1309M
          [INFO] ------------------------------------------------------------------------
          + rm -rf build/dist
          + mkdir -p build/dist
          + tar -C build/dist --strip-components=1 -xzf distribution/target/ycsb-0.4.0.tar.gz
          make[1]: Leaving directory '/home/sekikn/bigtop/output/ycsb/ycsb-0.4.0'
             dh_auto_test
           fakeroot debian/rules binary
          dh binary
             dh_testroot
             dh_prep
          	rm -f debian/ycsb.substvars
          	rm -f debian/ycsb.*.debhelper
          	rm -rf debian/ycsb/
             debian/rules override_dh_auto_install
          make[1]: Entering directory '/home/sekikn/bigtop/output/ycsb/ycsb-0.4.0'
          sh -x debian/install_ycsb.sh \
            --build-dir=build/dist \
            --prefix=debian/tmp
          
          (snip)
          
          W: ycsb: jar-not-in-usr-share usr/lib/ycsb/tarantool-binding/lib/tarantool-binding-0.4.0.jar
          Finished running lintian.
          
          BUILD SUCCESSFUL
          
          Total time: 8 mins 21.62 secs
          
          cos Konstantin Boudnik added a comment -

          Definitely, the objective of the patch seems to be achieved though

          cos Konstantin Boudnik added a comment -

          During the build of ycsb-deb I am getting this error

          [INFO] Tarantool DB Binding ............................... SUCCESS [ 14.080 s]
          [INFO] YCSB Release Distribution Builder .................. SUCCESS [01:01 min]
          [INFO] ------------------------------------------------------------------------
          [INFO] BUILD SUCCESS
          [INFO] ------------------------------------------------------------------------
          [INFO] Total time: 05:10 min
          [INFO] Finished at: 2016-10-25T02:41:23+00:00
          [INFO] Final Memory: 76M/258M
          [INFO] ------------------------------------------------------------------------
          + rm -rf build/dist
          + mkdir -p build/dist
          mkdir: cannot create directory 'build': Not a directory
          debian/rules:30: recipe for target 'override_dh_auto_build' failed
          make[1]: *** [override_dh_auto_build] Error 1
          make[1]: Leaving directory '/ws/output/ycsb/ycsb-0.4.0'
          debian/rules:27: recipe for target 'binary' failed
          make: *** [binary] Error 2
          dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 2
          debuild: fatal error at line 1376:
          dpkg-buildpackage -rfakeroot -D -us -uc -b
          

          Kengo Seki, do you see something similar? I am building in our docker image, although it could be a bit old.

          cos Konstantin Boudnik added a comment - - edited

          Will check this out over the weekend, thanks!

          sekikn Kengo Seki added a comment -

          Attaching a patch which addresses Konstantin Boudnik's comment. I confirmed ./gradlew deb -Dbuildwithdeps=true worked on Ubuntu.


            People

            • Assignee:
              sekikn Kengo Seki
              Reporter:
              sekikn Kengo Seki
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development