Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.0
    • Fix Version/s: 1.2.0
    • Component/s: None
    • Labels:
      None

      Description

      Voting on the way to release Phoenix 4.8.0... There are so many good features and fixes and also, it looks like integrations are working fine with current bigtop stack – HBase, Hive, Spark and Pig

      1. BIGTOP-2497.1.patch
        2 kB
        Kengo Seki
      2. BIGTOP-2497.2.patch
        2 kB
        Kengo Seki

        Activity

        sekikn Kengo Seki added a comment -

        Attaching a patch. In Addition to bigtop.bom, I modified do-component-build to avoid conflict in copying files with the same name in different directories. Without this fix, ./gradlew phoenix-pkg fails with the following error.

        + cp ./phoenix-tracing-webapp/target/phoenix-tracing-webapp-4.8.0-HBase-1.1-runnable.jar ./phoenix-tracing-webapp/target/phoenix-tracing-webapp-4.8.0-HBase-1.1-tests.jar ./phoenix-tracing-webapp/target/phoenix-tracing-webapp-4.8.0-HBase-1.1-sources.jar ./phoenix-tracing-webapp/target/phoenix-tracing-webapp-4.8.0-HBase-1.1.jar ./phoenix-spark/target/phoenix-spark-4.8.0-HBase-1.1-sources.jar ./phoenix-spark/target/phoenix-spark-4.8.0-HBase-1.1.jar ./phoenix-spark/target/phoenix-spark-4.8.0-HBase-1.1-tests.jar ./phoenix-pherf/target/phoenix-pherf-4.8.0-HBase-1.1-sources.jar ./phoenix-pherf/target/phoenix-pherf-4.8.0-HBase-1.1.jar ./phoenix-pherf/target/phoenix-pherf-4.8.0-HBase-1.1-tests.jar ./phoenix-pherf/target/phoenix-pherf-4.8.0-HBase-1.1-minimal.jar ./phoenix-queryserver-client/target/phoenix-4.8.0-HBase-1.1-thin-client.jar ./phoenix-queryserver-client/target/phoenix-queryserver-client-4.8.0-HBase-1.1-sources.jar ./phoenix-queryserver-client/target/phoenix-queryserver-client-4.8.0-HBase-1.1.jar ./phoenix-queryserver-client/target/phoenix-queryserver-client-4.8.0-HBase-1.1-tests.jar ./phoenix-queryserver/target/phoenix-queryserver-4.8.0-HBase-1.1.jar ./phoenix-queryserver/target/phoenix-queryserver-4.8.0-HBase-1.1-tests.jar ./phoenix-queryserver/target/phoenix-4.8.0-HBase-1.1-queryserver.jar ./phoenix-queryserver/target/phoenix-queryserver-4.8.0-HBase-1.1-sources.jar ./target/phoenix-4.8.0-HBase-1.1-tests.jar ./phoenix-core/target/phoenix-core-4.8.0-HBase-1.1.jar ./phoenix-core/target/phoenix-core-4.8.0-HBase-1.1-sources.jar ./phoenix-core/target/phoenix-core-4.8.0-HBase-1.1-tests.jar ./phoenix-pig/target/phoenix-pig-4.8.0-HBase-1.1.jar ./phoenix-pig/target/phoenix-pig-4.8.0-HBase-1.1-sources.jar ./phoenix-pig/target/phoenix-pig-4.8.0-HBase-1.1-tests.jar ./phoenix-flume/target/phoenix-flume-4.8.0-HBase-1.1-sources.jar ./phoenix-flume/target/phoenix-flume-4.8.0-HBase-1.1.jar ./phoenix-flume/target/phoenix-flume-4.8.0-HBase-1.1-tests.jar ./phoenix-server/target/phoenix-4.8.0-HBase-1.1-server.jar ./phoenix-client/                                                                       target/phoenix-4.8.0-HBase-1.1-client.jar ./phoenix-hive/target/phoenix-4.8.0-HBase-1.1-hive.jar ./phoenix-hive/target/dependency/phoenix-core-4.8.0-HBase-1.1.jar ./phoenix-hive/target/dependency/phoenix-core-4.8.0-HBase-1.1-tests.jar ./phoenix-hive/target/phoenix-hive-4.8.0-HBase-1.1-sources.jar ./phoenix-hive/target/phoenix-hive-4.8.0-HBase-1.1-tests.jar ./phoenix-hive/target/phoenix-hive-4.8.0-HBase-1.1.jar build/
        cp: will not overwrite just-created 'build/phoenix-core-4.8.0-HBase-1.1.jar' with './phoenix-hive/target/dependency/phoenix-core-4.8.0-HBase-1.1.jar'
        cp: will not overwrite just-created 'build/phoenix-core-4.8.0-HBase-1.1-tests.jar' with './phoenix-hive/target/dependency/phoenix-core-4.8.0-HBase-1.1-tests.jar'
        debian/rules:38: recipe for target 'override_dh_auto_build' failed
        

        BTW, 4.8.1 has also been released recently. Which version should we choose?

        https://lists.apache.org/thread.html/ee156cbb83cd234e1a36fa6a7454e299812da7ca407a77624ce913f7@%3Cuser.phoenix.apache.org%3E

        warwithin YoungWoo Kim added a comment -

        Kengo Seki Sorry for my tardiness. I believe 4.8.1 would be nice to have and please fix this failure on phoenix-rpm task:

        :buildSrc:compileJava UP-TO-DATE
        :buildSrc:compileGroovy UP-TO-DATE
        :buildSrc:processResources UP-TO-DATE
        :buildSrc:classes UP-TO-DATE
        :buildSrc:jar UP-TO-DATE
        :buildSrc:assemble UP-TO-DATE
        :buildSrc:compileTestJava UP-TO-DATE
        :buildSrc:compileTestGroovy UP-TO-DATE
        :buildSrc:processTestResources UP-TO-DATE
        :buildSrc:testClasses UP-TO-DATE
        :buildSrc:test UP-TO-DATE
        :buildSrc:check UP-TO-DATE
        :buildSrc:build UP-TO-DATE
        :phoenix_vardefines
        :phoenix-clean
        :phoenix-download
        Download https://archive.apache.org/dist//phoenix/apache-phoenix-4.8.0-HBase-1.1/src/apache-phoenix-4.8.0-HBase-1.1-src.tar.gz
        :phoenix-tar
        Copy /vagrant/bigtop/dl/apache-phoenix-4.8.0-HBase-1.1-src.tar.gz to /vagrant/bigtop/build/phoenix/tar/apache-phoenix-4.8.0-HBase-1.1-src.tar.gz
        :phoenix-srpm
        error: File /vagrant/bigtop/build/phoenix/rpm/SOURCES/phoenix-4.8.0-HBase-1.1-src.tar.gz: No such file or directory
        :phoenix-srpm FAILED
        
        FAILURE: Build failed with an exception.
        
        * Where:
        Script '/vagrant/bigtop/packages.gradle' line: 522
        
        * What went wrong:
        Execution failed for task ':phoenix-srpm'.
        > Process 'command 'rpmbuild'' finished with non-zero exit value 1
        

        Looks like the artifact for Phoenix src have changed at 4.8.0 so you should update rpm spec file too.

        Thanks!

        sekikn Kengo Seki added a comment -

        Thanks for the review YoungWoo Kim. Yeah, its naming rule seems to be changed from 4.8.0.
        I updated the patch and confirmed both ./gradlew phoenix-rpm on CentOS 7.2 and ./gradlew phoenix-deb on Ubuntu 16.04 worked.

        warwithin YoungWoo Kim added a comment -

        +1

        warwithin YoungWoo Kim added a comment -

        Committed. Thanks Kengo Seki!


          People

          • Assignee:
            sekikn Kengo Seki
            Reporter:
            warwithin YoungWoo Kim
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development