Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-2473

Mahout puppet script fails to find Package[hadoop]

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.0
    • Fix Version/s: 1.2.0
    • Component/s: None
    • Labels:

      Description

      Deploying role "mahout-client" fails with "Could not find dependency Package[hadoop]"

      Using the following site.yaml:

      bigtop::bigtop_repo_uri: http://bigtop-repos.s3.amazonaws.com/releases/1.1.0/ubuntu/trusty/x86_64
      bigtop::hadoop_head_node: head.node.fqdn
      bigtop::jdk_preinstalled: true
      bigtop::roles:
      - mahout-client
      bigtop::roles_enabled: true
      hadoop::common_hdfs::namenode_datanode_registration_ip_hostname_check: true
      hadoop::common_yarn::yarn_nodemanager_vmem_check_enabled: false
      hadoop::hadoop_storage_dirs:
      - /data/1
      - /data/2
      

      You get the following error:

      Error: Could not find dependency Package[hadoop] for Package[mahout] at /home/ubuntu/bigtop.release/bigtop-1.1.0/bigtop-deploy/puppet/modules/mahout/manifests/init.pp:30
      

      A patch is underway!

        Attachments

        1. BIGTOP-2473.patch
          0.8 kB
          Konstantinos Tsakalozos

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                ktsakalozos Konstantinos Tsakalozos
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: