Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.0
    • Fix Version/s: 1.2.0
    • Component/s: qfs
    • Labels:
      None

      Description

      See https://ci.bigtop.apache.org/job/Bigtop-trunk-packages/BUILD_ENVIRONMENTS=fedora-20,COMPONENTS=qfs,label=docker-slave/166/console

      :qfs-rpmerror: Failed build dependencies:
      	boost-devel >= 1.3.4 is needed by qfs-1.1.4-1.fc20.x86_64
      	libuuid-devel is needed by qfs-1.1.4-1.fc20.x86_64
      	xfsprogs-devel is needed by qfs-1.1.4-1.fc20.x86_64
      
      1. build.log
        1.94 MB
        Faraaz Sareshwala

        Issue Links

          Activity

          fsareshwala Faraaz Sareshwala added a comment -

          Hm, I haven't been able to reproduce this on my local testing environment. I've attached the output from my local build so you can inspect it if you choose.

          Has the toolchain been re-run on the jenkins build boxes? QFS depends on some other dependencies which have been added to the toolchain target within gradle. Likely, it will need to be rerun in order to install the dependencies. I'll make a subtask of this ticket to get that done.

          fsareshwala Faraaz Sareshwala added a comment -

          Note that in the build.log attachment, there is a command at the very top that states

          [root@localhost bigtop]# vim bigtop_toolchain/manifests/env.pp bigtop_toolchain/manifests/user.pp
          2 files to edit
          

          This was me adding quotes to the modes of various files. Apparently my puppet version doesn't like integers for modes.

          fsareshwala Faraaz Sareshwala added a comment -

          Adding a link of a previously closed issue that needs to be done in order to get this working.

          oflebbe Olaf Flebbe added a comment -

          It seems that the push of the updated bigtop/slaves did not go throgh and slaves without the updated docker images have been picked up. We'll should monitor it.

          fsareshwala Faraaz Sareshwala added a comment -

          Hi Olaf,

          I'm confused by your comment. Are you saying that the problem is fixed?

          oflebbe Olaf Flebbe added a comment -

          Hi Faraaz,

          Hopefully. We'll see tomorrow if the build is going through, finally. I appended the build to POWER8, too.

          oflebbe Olaf Flebbe added a comment -

          Yes, you are right. The interesting part is that it was on docker-slave-06 – this is the node we are building our docker images.

          The other interesting data point is that build #175 centos7 failed while building on docker-slave-07.

          I looked at the output of the push job Bigtop-toolchain-trunk-push . It had a failure , and the Bigtop-toolchain-trunk-pull job was never executed. So I rerun the push script and the pull script have now been executed on all nodes, so the changes to the toolchain should be live now. (Hopefully)

          Sounds confusing? surely it is.

          fsareshwala Faraaz Sareshwala added a comment -

          Awesome. I'll close out the required tickets.


            People

            • Assignee:
              fsareshwala Faraaz Sareshwala
              Reporter:
              oflebbe Olaf Flebbe
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development