Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.0
    • Fix Version/s: 1.1.0
    • Component/s: tests
    • Labels:
      None

      Description

      While running on a single node cluster, TestBlockRecovery fails with AssumtionViolationException. Turns out Assume shouldn't be used in @BeforeClass and @AfterClass methods.

      While it might be untypical to run such a test in the single node setup, it is yet convenient during the development cycle and incorrectly failing test is spoiling the picture. Let's fix.

        Activity

        cos Konstantin Boudnik added a comment -

        This is rather an improvement and not a bug. I had to move a bit of the code from setup method into the class itself, to avoid breaking the asserts if the test was skipped.

        Will check if my changes do not break a fully-distributed cluster tomorrow and if everything is fine, will commit this.

        evans_ye Evans Ye added a comment -

        Sorry I guess this is tangential. The implicit requirement of 3 datanodes is hard to discover without digging into the testing code. Can we add some notes when the test fail?
        Anyhow the patch looks good to me w/o a test.

        cos Konstantin Boudnik added a comment -

        Actually, without at least three nodes the test wouldn't fail - it will just be skipped. But sure - I will add a piece of javadoc to it. I have discovered some weirdness on the three-nodes cluster - not sure if it because of the docker or else - will dig a little further. Thanks!

        cos Konstantin Boudnik added a comment -

        A bit more advanced fix. Confirmed to work properly. Ready for commit.

        cos Konstantin Boudnik added a comment -

        Pushed to the master


          People

          • Assignee:
            cos Konstantin Boudnik
            Reporter:
            cos Konstantin Boudnik
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development