Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-2181

Setting Ignite version to use '.' broke Zeppelin build.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.1.0
    • Fix Version/s: 1.1.0
    • Component/s: build
    • Labels:
      None

      Description

      Zeppelin build can not proceed because of

      [ERROR] Failed to execute goal on project zeppelin-ignite: Could not resolve dependencies for project org.apache.zeppelin:zeppelin-ignite:jar:0.5.5-incubating: The following artifacts could not be resolved: org.apache.ignite:ignite-core:jar:1.5.0.b1, org.apache.ignite:ignite-spring:jar:1.5.0.b1, org.apache.ignite:ignite-indexing:jar:1.5.0.b1, org.apache.ignite:ignite-scalar:jar:1.5.0.b1: Could not find artifact org.apache.ignite:ignite-core:jar:1.5.0.b1 in default (http://localhost:8081/content/repositories/central/) -> [Help 1]
      
      1. BIGTOP-2181.patch
        1 kB
        Sergey Soldatov

        Issue Links

          Activity

          sergey.soldatov Sergey Soldatov added a comment -

          As a temporary solution sets an explicit version of ignite for building zeppelin.

          cos Konstantin Boudnik added a comment -

          While this is effectively rolls-back BIGTOP-2166 and isn't pretty, I think this is the only thing we can reasonably do here. This all is caused by weird version number in the latest Ignite release. The community is aware about the problem and hopefully they won't do another one with such a nasty version schema.

          cos Konstantin Boudnik added a comment -

          +1 - will commit it shortly.

          cos Konstantin Boudnik added a comment -

          Pushed to the master. Thanks Sergey!


            People

            • Assignee:
              sergey.soldatov Sergey Soldatov
              Reporter:
              cos Konstantin Boudnik
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development