Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-2138

deb: make bigtop-jsvc a wrapper package for jsvc package

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.0.0
    • Fix Version/s: 1.2.0
    • Component/s: build, debian, ppc64le
    • Labels:
      None

      Description

      There is no need to supply an own jsvc daemon executable, at least not for debian and ubuntu.

      Make bigtop-jsvc a wrapper package for the jsvc package, placing a symlink to the correct executable.

      Fixes a problem with POWER8 btw.

        Issue Links

          Activity

          oflebbe Olaf Flebbe added a comment -

          There are other solutions now in place

          oflebbe Olaf Flebbe added a comment -

          Of course, yes. I quick fix is already in place.

          cos Konstantin Boudnik added a comment -

          Can we hold off committing this patch for a couple days so I can branch of 1.1 release first? Thanks!

          oflebbe Olaf Flebbe added a comment -

          Yep. I link the alternative solution for 1.1 to this ticket in a minute.

          cos Konstantin Boudnik added a comment -

          This ticket then should be moved to 1.2 from 1.1, right?

          cos Konstantin Boudnik added a comment -

          Thank you Olaf! Let's do as you proposed. I don't see why we should forever carry over old crap like Centos6

          oflebbe Olaf Flebbe added a comment -

          Hm, your concern regarding Centos-6 is valid, since jsvc in Centos6 is not usable.

          But every other distro has a good and running jsvc and I see absolutly no point in replacing a running and maintained package.
          As a compromise, let me fix jsvc in Bigtop 1.1 and push this particular ticket to 1.2 . My proposal was to remove centos6 in 1.2 and check whether your concerns are valid.

          Amir presented a fix a possible solution a few weeks ago, let me put this fix in in a different JIRA for 1.1 in order to move forward.

          cos Konstantin Boudnik added a comment -

          So, my concern in the first comment was addressed?

          asanjar Amir Sanjar added a comment -

          rebuild and smoke-test the entire stack on x86 too. no regression.

          asanjar Amir Sanjar added a comment -

          +1 on the patch.

          oflebbe Olaf Flebbe added a comment -

          Thanks Ayappan! Leaving out jsvc , will let us save the time to porting jsvc to the power8le arch. This is already done by the distro, there is no point in redoing it.

          The concrete Version of jsvc does not matter, the distro should maintain it securitywise... functioanltiywise jsvc is not a big issue, afaik.

          Olaf

          Ayappan Ayappan added a comment -

          Both Ubuntu 14.04 & 15.04 has jsvc 1.0.15 version.
          Traditionally PowerPC was considered as a Big Endian arch (ppc64) but that is not the case any more. We have ppc64le as well right now.
          So in the safer side it seems like using the distro's jsvc will be a better option for all the archs & distros,

          cos Konstantin Boudnik added a comment -

          Historically, jsvc wasn't available from standard repo, hence our own package for it. Right now it seems to be a part of standard Ubuntu 12.04 and later (and evidently Debian). However, on Centos6 the version is 1.0.1-8.9, which is real old (as anything else on CentOS, of course), and even for Centos7 it sits at 1.0.13.
          Are we saving a lot by not building it for Debian platforms? And can we guarantee that ubuntu 14.04 will have the same version as 15.04 or 12.04? While chances are slim, there's a possibility that different versions might behave somewhat differently. E.g. I know that 1.0.1 doesn't support some standard Java options.


            People

            • Assignee:
              oflebbe Olaf Flebbe
              Reporter:
              oflebbe Olaf Flebbe
            • Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development