Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.0
    • Fix Version/s: backlog, 1.2.0
    • Component/s: hbase
    • Labels:
      None
    • Environment:

      From our unconference @ApacheCon: looks like Hbase 1.1 (or 1.2 as it might come out of the woodworks soon) is good and stable.

      Shall we bump up our version in the next release?

      Description

      Time to upgrade to HBase 1.1.x

        Issue Links

          Activity

          githubbot ASF GitHub Bot added a comment -

          GitHub user youngwookim opened a pull request:

          https://github.com/apache/bigtop/pull/49

          BIGTOP-2077. Bump HBase version to 1.1

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/youngwookim/bigtop BIGTOP-2027

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/bigtop/pull/49.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #49


          commit 25d950f7c5d9f4e262cd77e05e2f2e97c2f995c2
          Author: YoungWoo Kim <ywkim@apache.org>
          Date: 2015-11-07T15:07:16Z

          BIGTOP-2077. Bump HBase version to 1.1


          warwithin YoungWoo Kim added a comment -

          Send a pull request for HBase 1.1 but ycsb build will fail I'll address that issue in BIGTOP-2102

          githubbot ASF GitHub Bot added a comment -

          GitHub user youngwookim opened a pull request:

          https://github.com/apache/bigtop/pull/50

          BIGTOP-2077. Bump HBase version to 1.1

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/youngwookim/bigtop BIGTOP-2077

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/bigtop/pull/50.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #50


          commit 25d950f7c5d9f4e262cd77e05e2f2e97c2f995c2
          Author: YoungWoo Kim <ywkim@apache.org>
          Date: 2015-11-07T15:07:16Z

          BIGTOP-2077. Bump HBase version to 1.1


          apurtell Andrew Purtell added a comment -

          Where would this go in? Master branch only? The BOM for 1.1 includes 0.98 still (BIGTOP-2118).

          Not all components are compatible with HBase 1.1. Pig, for example, will be unable to compile its HBase support because the last version of HBase supporting Hadoop 1 is 0.98.x. Perhaps it's an issue more in the context of Pig component maintenance than HBase but worth mentioning because I recently discussed it on PIG-4728

          cos Konstantin Boudnik added a comment -

          How about we do it on a branch until everything is stabilized? Otherwise, this fix will rot over the time.

          warwithin YoungWoo Kim added a comment - - edited

          Andrew Purtell, Thanks for the link but I can not reproduce PIG-4728 with my patch(HBase 1.1.2) I could not find any error from '''./gradlew pig-clean pig-rpm''' Any idea on this?

          apurtell Andrew Purtell added a comment -

          Any idea on this?

          I don't build Pig or deal with it so I can't help. I forwarded their assessment that they're not ready to move up to HBase 1.x because it drops support for Hadoop 1, and this leads to build issues. If we don't see that... ok, I guess.

          Even so, this JIRA is in current conflict with the BOM for Bigtop 1.1 and BIGTOP-2118. So which way do we resolve the conflict?

          cos Konstantin Boudnik added a comment -

          Adding a few JIRA links that back in a day seemed like related to the upgrade.

          evans_ye Evans Ye added a comment -

          The branch idea is good. We can have a packaging CI job for that branch so that we can get a clear view for which components are having compatibility issues. It's a pity to let the patch rot.

          sumeetmaru Sumeetkumar Maru added a comment -

          What is the blocker for this patch? Can we get this into mainline?

          githubbot ASF GitHub Bot added a comment -

          Github user youngwookim closed the pull request at:

          https://github.com/apache/bigtop/pull/50

          githubbot ASF GitHub Bot added a comment -

          Github user youngwookim closed the pull request at:

          https://github.com/apache/bigtop/pull/49

          warwithin YoungWoo Kim added a comment -

          Sumeetkumar Maru, I'm investigating compatibility between upstream projects and HBase 1.1
          In most case, I believe it should work

          Will send a pull request for WIP patch.

          githubbot ASF GitHub Bot added a comment -

          GitHub user youngwookim opened a pull request:

          https://github.com/apache/bigtop/pull/88

          BIGTOP-2077. Bump HBase version to 1.1

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/youngwookim/bigtop BIGTOP-2077

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/bigtop/pull/88.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #88


          commit f530e93c259efdc7121f8772b45ae65a215236c8
          Author: Youngwoo Kim <ywkim@apache.org>
          Date: 2016-02-11T11:03:17Z

          BIGTOP-2077. Bump HBase version to 1.1


          warwithin YoungWoo Kim added a comment -

          Pull request for HBase 1.1

          I would like to file a separate JIRA(BIGTOP-2333) to address an issue on HBase 1.1 integration for Pig (send a pull request too) To make Pig work with HBase 1.1 on Hadoop 2, in BIGTOP-2333 I did apply Daniel's patch to 0.15.0 from PIG-4728 (but slightly modified)

          What do you think? Andrew Purtell, Konstantin Boudnik

          apurtell Andrew Purtell added a comment -

          +1, go ahead, I trust you that you have a way to make Pig work with HBase 1.1 at least in our generated convenience artifacts.

          Please be advised no version of Phoenix works with HBase 1.2 yet, so we need to stick with 1.1.

          jonathak Jonathan Kelly added a comment -

          Regarding Phoenix on HBase 1.2, we are trying to fix this in https://issues.apache.org/jira/browse/PHOENIX-2833.

          cos Konstantin Boudnik added a comment -

          Sergey Soldatov, I know that you're working with Phoenix like a lot lately: any comments on this combination? Is it ready for the prime time?

          sergey.soldatov Sergey Soldatov added a comment -

          Konstantin Boudnik Definitely HBase 1.1 is the best choice for Phoenix atm. Hope we're talking about Phoenix 4.7

          warwithin YoungWoo Kim added a comment -

          Sorry for the delay. I'll commit this and BIGTOP-2333 Thanks!

          githubbot ASF GitHub Bot added a comment -

          Github user asfgit closed the pull request at:

          https://github.com/apache/bigtop/pull/88


            People

            • Assignee:
              warwithin YoungWoo Kim
              Reporter:
              cos Konstantin Boudnik
            • Votes:
              0 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development