Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-2040

Mahout can not be build with Maven 3.0.5 - build containers need to be upgraded

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.0
    • Fix Version/s: 1.1.0
    • Component/s: build
    • Labels:
      None

      Description

      Looking at http://bigtop01.cloudera.org:8080/view/Bigtop-trunk/job/Docker-Bigtop-trunk-Mahout/BUILD_ENVIRONMENTS=centos-6,label=docker-slave-01/163/console I see that Mahout fails because

      05:31:51  [WARNING] Rule 1: org.apache.maven.plugins.enforcer.RequireMavenVersion failed with message:
      05:31:51  Detected Maven Version: 3.0.5 is not in the allowed range [3.3.3,).
      05:31:51  [INFO] ------------------------------------------------------------------------
      05:31:51  [INFO] Reactor Summary:
      05:31:51  [INFO] 
      05:31:51  [INFO] Mahout Build Tools ................................ FAILURE [4.977s]
      05:31:51  [INFO] Apache Mahout ..................................... SKIPPED
      05:31:51  [INFO] Mahout Math ....................................... SKIPPED
      05:31:51  [INFO] Mahout HDFS ....................................... SKIPPED
      05:31:51  [INFO] Mahout Map-Reduce ................................. SKIPPED
      05:31:51  [INFO] Mahout Integration ................................ SKIPPED
      05:31:51  [INFO] Mahout Examples ................................... SKIPPED
      05:31:51  [INFO] Mahout Math Scala bindings ........................ SKIPPED
      05:31:51  [INFO] Mahout H2O backend ................................ SKIPPED
      05:31:51  [INFO] Mahout Spark bindings ............................. SKIPPED
      05:31:51  [INFO] Mahout Spark bindings shell ....................... SKIPPED
      05:31:51  [INFO] Mahout Release Package ............................ SKIPPED
      05:31:51  [INFO] ------------------------------------------------------------------------
      05:31:51  [INFO] BUILD FAILURE
      05:31:51  [INFO] ------------------------------------------------------------------------
      05:31:51  [INFO] Total time: 7.908s
      05:31:51  [INFO] Finished at: Sun Sep 13 05:31:38 UTC 2015
      05:31:52  [INFO] Final Memory: 13M/404M
      05:31:52  [INFO] ------------------------------------------------------------------------
      05:31:52  [ERROR] Failed to execute goal org.apache.maven.plugins:maven-enforcer-plugin:1.4:enforce (enforce-versions) on project mahout-buildtools: Some Enforcer rules have failed. Look above for specific messages explaining why the rule failed. -> [Help 1]
      

        Activity

        Hide
        evans_ye Evans Ye added a comment -

        I'll update once BIGTOP-2017 is in.

        Show
        evans_ye Evans Ye added a comment - I'll update once BIGTOP-2017 is in.
        Hide
        cos Konstantin Boudnik added a comment -

        I think this has been effectively resolved, isn't it? Evans Ye, could you please confirm or otherwise?

        Show
        cos Konstantin Boudnik added a comment - I think this has been effectively resolved, isn't it? Evans Ye , could you please confirm or otherwise?
        Hide
        evans_ye Evans Ye added a comment -

        Yes. The images has been upgraded. Close this as fixed.

        Show
        evans_ye Evans Ye added a comment - Yes. The images has been upgraded. Close this as fixed.

          People

          • Assignee:
            evans_ye Evans Ye
            Reporter:
            cos Konstantin Boudnik
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development