Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-1977

Enforce valid Maven version range

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Invalid
    • Affects Version/s: 1.0.0
    • Fix Version/s: 1.0.1
    • Component/s: build
    • Labels:
      None

      Description

      Maven 3.0.x is currently required for building Bigtop 1.0 because of issues with Crunch and Tez builds (MNG-5482, MNG-5787, MNG-5787). Let's use the maven-enforcer-plugin to fail the build right away if a too recent version of Maven is in use.

        Attachments

        1. BIGTOP-1977.patch
          1 kB
          Andrew Kyle Purtell

          Issue Links

            Activity

              People

              • Assignee:
                apurtell Andrew Kyle Purtell
                Reporter:
                apurtell Andrew Kyle Purtell
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: