Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-1902

typo in bigtop-deploy/vm/vagrant-puppet-vm/vagrantconfig.yaml

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.0.0, 1.1.0
    • Fix Version/s: 1.0.0, 1.1.0
    • Component/s: deployment
    • Labels:
      None

      Description

      so `mapreduce` is typed as `mapredcue` which is not that big of a deal, because if users set `run_smoke_tests: true` the smoke tests of mapreduce will run smoothly because it's spelled right in bigtop-deploy/vm/utils/smoke-tests.sh ... but still.

        Activity

        Hide
        oflebbe Olaf Flebbe added a comment -

        Is this the change you are proposing? Please review.

        Changing tags since trunk is now targeting release 1.1

        Show
        oflebbe Olaf Flebbe added a comment - Is this the change you are proposing? Please review. Changing tags since trunk is now targeting release 1.1
        Hide
        mylu Minying Lu added a comment -

        Yes, thank you.

        Show
        mylu Minying Lu added a comment - Yes, thank you.
        Hide
        mylu Minying Lu added a comment -

        typo corrected in patch

        Show
        mylu Minying Lu added a comment - typo corrected in patch
        Hide
        evans_ye Evans Ye added a comment -

        Thank you Minying Lu for discovering the typo. Actually I think the mapreduce smoke-test should be broken since the correct spelled setting in bigtop-deploy/vm/utils/smoke-tests.sh can only be activated when smoke_test_components is empty. The patch looks good. I've committed this in master and 1.0 branch.
        Thanks Olaf Flebbe.
        Minying Lu you can also try to provide patch for any bug you spotted in bigtop. Here's the guide for contributor, and you can ask in mailing list if you have questions.

        Show
        evans_ye Evans Ye added a comment - Thank you Minying Lu for discovering the typo. Actually I think the mapreduce smoke-test should be broken since the correct spelled setting in bigtop-deploy/vm/utils/smoke-tests.sh can only be activated when smoke_test_components is empty. The patch looks good. I've committed this in master and 1.0 branch. Thanks Olaf Flebbe . Minying Lu you can also try to provide patch for any bug you spotted in bigtop. Here's the guide for contributor , and you can ask in mailing list if you have questions.

          People

          • Assignee:
            oflebbe Olaf Flebbe
            Reporter:
            mylu Minying Lu
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development