Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-1874

HBase build failed due to Codehaus repository is out of service

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 1.0.0
    • Component/s: hbase
    • Labels:
      None

      Description

      It seems that the codehaus repo is out of service and causing the hbase build not being able to download its dependencies . I encounter this first on the HBase nightly build, then manually tested on 4 docker build slaves separately. The results are consistent.

        Issue Links

          Activity

          Hide
          evans_ye Evans Ye added a comment -

          Attach the patch to disable codehaus repository when packaging HBase. The upstream HBase release seems still have codehaus enabled in its newest release so I guess there''s no chance to fix this by upgrading HBase.

          Show
          evans_ye Evans Ye added a comment - Attach the patch to disable codehaus repository when packaging HBase. The upstream HBase release seems still have codehaus enabled in its newest release so I guess there''s no chance to fix this by upgrading HBase.
          Hide
          warwithin YoungWoo Kim added a comment -

          Same problem on my end I'll commit the patch if it works. Thanks!

          Show
          warwithin YoungWoo Kim added a comment - Same problem on my end I'll commit the patch if it works. Thanks!
          Hide
          evans_ye Evans Ye added a comment -

          Glad I find someone accompany with me.
          I wonder does HBase also need to fix this as well? Since I can see the newest HBase 1.1 release still have codehaus repository enabled. I'm not quite familiar with HBase yet, Andrew Purtell do you think this is valid?

          Show
          evans_ye Evans Ye added a comment - Glad I find someone accompany with me. I wonder does HBase also need to fix this as well? Since I can see the newest HBase 1.1 release still have codehaus repository enabled. I'm not quite familiar with HBase yet, Andrew Purtell do you think this is valid?
          Hide
          warwithin YoungWoo Kim added a comment -

          +1,

          It works fine on packaging hbase deb and rpm. Will commit it shortly. Thanks Evans Ye!

          Show
          warwithin YoungWoo Kim added a comment - +1, It works fine on packaging hbase deb and rpm. Will commit it shortly. Thanks Evans Ye !
          Hide
          apurtell Andrew Purtell added a comment -

          We will need to fix this upstream. Let me make that change. If/when we update to HBase 0.98.13 or later the fix will be there.

          Show
          apurtell Andrew Purtell added a comment - We will need to fix this upstream. Let me make that change. If/when we update to HBase 0.98.13 or later the fix will be there.
          Hide
          apurtell Andrew Purtell added a comment -

          +1 for the fix here for now

          Show
          apurtell Andrew Purtell added a comment - +1 for the fix here for now
          Hide
          evans_ye Evans Ye added a comment -

          thanks for clarifying.

          Show
          evans_ye Evans Ye added a comment - thanks for clarifying.

            People

            • Assignee:
              evans_ye Evans Ye
              Reporter:
              evans_ye Evans Ye
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development